summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2002-05-21 18:17:54 (GMT)
committermdejong <mdejong>2002-05-21 18:17:54 (GMT)
commit6894740029f61262bf530094fe3975e078f69321 (patch)
tree67fc2c34f8ee8dcca0424a1e00800bcd053824a4 /unix/configure.in
parente0c4b53d5b6dd002350c769dbb457b715f63daed (diff)
downloadtcl-6894740029f61262bf530094fe3975e078f69321.zip
tcl-6894740029f61262bf530094fe3975e078f69321.tar.gz
tcl-6894740029f61262bf530094fe3975e078f69321.tar.bz2
* unix/configure: Regen.
* unix/configure.in: Invoke SC_ENABLE_SHARED before calling SC_CONFIG_CFLAGS so that the SHARED_BUILD variable can be checked inside SC_CONFIG_CFLAGS. * unix/tcl.m4 (SC_CONFIG_CFLAGS): Pass -non_shared instead of -shared to ld when configured with --disable-shared under OSF. [Tcl bug 540390]
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index be5cbbc..9dcc86f 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.83 2002/03/06 15:20:23 dkf Exp $
+# RCS: @(#) $Id: configure.in,v 1.84 2002/05/21 18:17:55 mdejong Exp $
AC_INIT(../generic/tcl.h)
@@ -377,6 +377,8 @@ SC_TCL_LINK_LIBS
LIBS="$LIBS$THREADS_LIBS"
+SC_ENABLE_SHARED
+
#--------------------------------------------------------------------
# The statements below define a collection of compile flags. This
# macro depends on the value of SHARED_BUILD, and should be called
@@ -406,8 +408,6 @@ SC_BLOCKING_STYLE
TCL_UNSHARED_LIB_SUFFIX=${UNSHARED_LIB_SUFFIX}
TCL_SHARED_LIB_SUFFIX=${SHARED_LIB_SUFFIX}
-SC_ENABLE_SHARED
-
TCL_LD_SEARCH_FLAGS="${LD_SEARCH_FLAGS}"
if test "${SHARED_BUILD}" = "1" -a "${SHLIB_SUFFIX}" != "" ; then
TCL_SHLIB_CFLAGS="${SHLIB_CFLAGS}"