summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2001-06-26 20:13:20 (GMT)
committermdejong <mdejong>2001-06-26 20:13:20 (GMT)
commit6e78ca3bfaefa925f074070ac7788fd278271283 (patch)
treefa853605d01f77957018424a0fd85d7b5f055ee1 /unix/configure.in
parent8f2d7d9c0c6cc1877c74aba39be24687c6791c32 (diff)
downloadtcl-6e78ca3bfaefa925f074070ac7788fd278271283.zip
tcl-6e78ca3bfaefa925f074070ac7788fd278271283.tar.gz
tcl-6e78ca3bfaefa925f074070ac7788fd278271283.tar.bz2
* unix/configure: Regen.
* unix/configure.in: Set CFLAGS to "" if the user did not set CFLAGS in the env. This keeps AC_PROG_CC from adding "-g -O2" to the CFLAGS by default. * win/configure: Regen. * win/configure.in: Ditto.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 1a91996..1b04714 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tcl.h)
-# RCS: @(#) $Id: configure.in,v 1.67 2001/06/22 23:02:53 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.68 2001/06/26 20:13:20 mdejong Exp $
TCL_VERSION=8.4
TCL_MAJOR_VERSION=8
@@ -27,6 +27,12 @@ TCL_SRC_DIR=`cd $srcdir/..; pwd`
# Standard compiler checks
#------------------------------------------------------------------------
+# If the user did not set CFLAGS, set it now to keep
+# the AC_PROG_CC macro from adding "-g -O2".
+if test "${CFLAGS+set}" != "set" ; then
+ export CFLAGS=""
+fi
+
AC_PROG_CC
AC_PROG_RANLIB
AC_HAVE_HEADERS(unistd.h limits.h)