summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2000-01-12 11:13:54 (GMT)
committerhobbs <hobbs>2000-01-12 11:13:54 (GMT)
commitada01064f7bee2a0d9103cbf33a62d95fc4f5ea0 (patch)
tree330a348f974e0dfe1c201adc2b1fe77058474ebc /unix/configure.in
parentf0c936b8a5365ec18f126e2c15715509d64bb440 (diff)
downloadtcl-ada01064f7bee2a0d9103cbf33a62d95fc4f5ea0.zip
tcl-ada01064f7bee2a0d9103cbf33a62d95fc4f5ea0.tar.gz
tcl-ada01064f7bee2a0d9103cbf33a62d95fc4f5ea0.tar.bz2
* tests/unixFCmd.test:
* unix/tclUnixFCmd.c: added support for symbolic permissions setting in SetPermissionsAttribute (file attr $file -perm ...) [Bug: 3970] * tests/expr.test: * unix/Makefile.in: * unix/configure.in: * unix/tcl.m4: strtod bug on Tru64 [Bug: 3378] and added tests to prevent unnecessary chmod +x in sources while installing, as well as more intelligent setsockopt/gethostbyname checks [Bug: 3366, 3389] * unix/tclUnixThrd.c: added compile time support (through use of the TCL_THREAD_STACK_MIN define) for increasing the default stack size for a thread. [Bug: 3797, 1966]
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in26
1 files changed, 2 insertions, 24 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 922676f..fd0e84e 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -2,7 +2,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tcl.h)
-# RCS: @(#) $Id: configure.in,v 1.52 1999/12/21 23:59:49 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.53 2000/01/12 11:13:55 hobbs Exp $
TCL_VERSION=8.3
TCL_MAJOR_VERSION=8
@@ -254,29 +254,7 @@ fi
# "fixstrtod" that corrects the error.
#--------------------------------------------------------------------
-AC_CHECK_FUNC(strtod, tcl_strtod=1, tcl_strtod=0)
-if test "$tcl_strtod" = 1; then
- AC_MSG_CHECKING([for Solaris strtod bug])
- AC_TRY_RUN([
-extern double strtod();
-int main()
-{
- char *string = "NaN";
- char *term;
- strtod(string, &term);
- if ((term != string) && (term[-1] == 0)) {
- exit(1);
- }
- exit(0);
-}], tcl_ok=1, tcl_ok=0, tcl_ok=0)
- if test $tcl_ok = 1; then
- AC_MSG_RESULT(ok)
- else
- AC_MSG_RESULT(buggy)
- LIBOBJS="$LIBOBJS fixstrtod.o"
- AC_DEFINE(strtod, fixstrtod)
- fi
-fi
+SC_BUGGY_STRTOD
#--------------------------------------------------------------------
# Check for various typedefs and provide substitutes if