summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2002-05-30 03:27:09 (GMT)
committerhobbs <hobbs>2002-05-30 03:27:09 (GMT)
commitb464ac8106dd466c8fc7ae3018e205bf0d69ef5f (patch)
tree2ac8f1f6e76a23dd45fffcc5b2d2f6a928444c32 /unix/configure.in
parent06a24b87b9c810cdda2178d9b076750f15348a0b (diff)
downloadtcl-b464ac8106dd466c8fc7ae3018e205bf0d69ef5f.zip
tcl-b464ac8106dd466c8fc7ae3018e205bf0d69ef5f.tar.gz
tcl-b464ac8106dd466c8fc7ae3018e205bf0d69ef5f.tar.bz2
* unix/configure: regen'ed
* unix/configure.in: replaced bigendian check with autoconf standard AC_C_BIG_ENDIAN, which defined WORDS_BIGENDIAN on bigendian systems. * generic/tclUtf.c (Tcl_UniCharNcmp): * generic/tclInt.h (TclUniCharNcmp): use WORDS_BIGENDIAN instead of TCL_OPTIMIZE_UNICODE_COMPARE to enable memcmp alternative.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in28
1 files changed, 8 insertions, 20 deletions
diff --git a/unix/configure.in b/unix/configure.in
index ce4d7d9..5aeba9e 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.85 2002/05/29 10:35:46 dkf Exp $
+# RCS: @(#) $Id: configure.in,v 1.86 2002/05/30 03:27:09 hobbs Exp $
AC_INIT(../generic/tcl.h)
@@ -73,6 +73,13 @@ SC_TCL_EARLY_FLAGS
SC_TCL_64BIT_FLAGS
#--------------------------------------------------------------------
+# Check endianness because we can optimize comparisons of
+# Tcl_UniChar strings to memcmp on big-endian systems.
+#--------------------------------------------------------------------
+
+AC_C_BIGENDIAN
+
+#--------------------------------------------------------------------
# Supply substitutes for missing POSIX library procedures, or
# set flags so Tcl uses alternate procedures.
#--------------------------------------------------------------------
@@ -401,25 +408,6 @@ TCL_DBGX=${DBGX}
SC_BLOCKING_STYLE
#--------------------------------------------------------------------
-# The statements below check whether we can optimise comparisons
-# of Tcl_UniChar strings to memcmp; this only holds true on
-# big-endian systems, but we fall-back to not doing it when
-# cross-compiling because that is at least safe (if probably
-# slower when the guess is wrong.)
-#--------------------------------------------------------------------
-
-AC_MSG_CHECKING([for Unicode optimization opportunity])
-AC_CACHE_VAL(tcl_cv_flag_optimize_unicode,[
- AC_TRY_RUN([#include <unistd.h>
- int main() {union {char c[2];short s;} u; u.s=1; exit(u.c[0]);}
- ], tcl_cv_flag_optimize_unicode=yes, tcl_cv_flag_optimize_unicode=no,
- tcl_cv_flag_optimize_unicode=no)])
-AC_MSG_RESULT($tcl_cv_flag_optimize_unicode)
-if test "x$tcl_cv_flag_optimize_unicode" = "xyes"; then
- AC_DEFINE(TCL_OPTIMIZE_UNICODE_COMPARE)
-fi
-
-#--------------------------------------------------------------------
# The statements below define a collection of symbols related to
# building libtcl as a shared library instead of a static library.
#--------------------------------------------------------------------