summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2007-02-04 02:51:34 (GMT)
committerdas <das>2007-02-04 02:51:34 (GMT)
commitbaa5c737e07f4e6a6b343b7fe731da0ae38fdacc (patch)
treef0cde107e30e3c407eed609861ed73f67eb2c5a2 /unix/configure.in
parentb0221dde4d16171e7d4b79b860bcaf6935a6ff47 (diff)
downloadtcl-baa5c737e07f4e6a6b343b7fe731da0ae38fdacc.zip
tcl-baa5c737e07f4e6a6b343b7fe731da0ae38fdacc.tar.gz
tcl-baa5c737e07f4e6a6b343b7fe731da0ae38fdacc.tar.bz2
* unix/configure.in: add caching to -pipe check.
* unix/configure: autoconf-2.13
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in21
1 files changed, 10 insertions, 11 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 6f6eead..149a84d 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.33 2007/01/25 02:06:38 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.34 2007/02/04 02:51:37 das Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -62,16 +62,15 @@ SC_MISSING_POSIX_HEADERS
# It makes compiling go faster. (This is only a performance feature.)
#------------------------------------------------------------------------
-if test -z "$no_pipe"; then
-if test -n "$GCC"; then
- AC_MSG_CHECKING([if the compiler understands -pipe])
- OLDCC="$CC"
- CC="$CC -pipe"
- AC_TRY_COMPILE(,,
- AC_MSG_RESULT([yes]),
- CC="$OLDCC"
- AC_MSG_RESULT([no]))
-fi
+if test -z "$no_pipe" && test -n "$GCC"; then
+ AC_CACHE_CHECK([if the compiler understands -pipe],
+ tcl_cv_cc_pipe, [
+ hold_cflags=$CFLAGS; CFLAGS="$CFLAGS -pipe"
+ AC_TRY_COMPILE(,, tcl_cv_cc_pipe=yes, tcl_cv_cc_pipe=no)
+ CFLAGS=$hold_cflags])
+ if test $tcl_cv_cc_pipe = yes; then
+ CFLAGS="$CFLAGS -pipe"
+ fi
fi
#------------------------------------------------------------------------