summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2008-06-12 06:27:30 (GMT)
committerdas <das>2008-06-12 06:27:30 (GMT)
commitc03da332a842e384685d4205c7aef09ac9070fa7 (patch)
tree94377e8a297979d0d331d270bc7b0f7f732fe234 /unix/configure.in
parent723feae3b17d7cacc75afd5d54f798af90b02eec (diff)
downloadtcl-c03da332a842e384685d4205c7aef09ac9070fa7.zip
tcl-c03da332a842e384685d4205c7aef09ac9070fa7.tar.gz
tcl-c03da332a842e384685d4205c7aef09ac9070fa7.tar.bz2
* unix/configure.in: fix static DTrace-enabled build on Solaris.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index f59e281..f49c43c 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.182 2008/04/01 16:23:44 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.183 2008/06/12 06:27:30 das Exp $
AC_INIT([tcl],[8.6])
AC_PREREQ(2.59)
@@ -663,6 +663,15 @@ if test $tcl_ok = yes; then
DTRACE_HDR="\${DTRACE_HDR}"
if test "`uname -s`" != "Darwin" ; then
DTRACE_OBJ="\${DTRACE_OBJ}"
+ if test "`uname -s`" = "SunOS" -a "$SHARED_BUILD" = "0" ; then
+ # Need to create an intermediate object file to ensure tclDTrace.o
+ # gets included when linking against the static tcl library.
+ STLIB_LD='stlib_ld () { /usr/ccs/bin/ld -r -o $${1%.a}.o "$${@:2}" && '"${STLIB_LD}"' $${1} $${1%.a}.o ; } && stlib_ld'
+ # Force use of Sun ar and ranlib, the GNU versions choke on
+ # tclDTrace.o and the combined object file above.
+ AR='/usr/ccs/bin/ar'
+ RANLIB='/usr/ccs/bin/ranlib'
+ fi
fi
fi
AC_MSG_RESULT([$tcl_ok])