summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2007-11-15 04:16:26 (GMT)
committerdas <das>2007-11-15 04:16:26 (GMT)
commitc40712d24f8def6f6ad3a484103fdfdba35cbf10 (patch)
tree21da25e56f965a2f1797e99f35f4c4160be06dec /unix/configure.in
parent54ea465b4599cd6b7fa8455cbc95bf4a43b3d817 (diff)
downloadtcl-c40712d24f8def6f6ad3a484103fdfdba35cbf10.zip
tcl-c40712d24f8def6f6ad3a484103fdfdba35cbf10.tar.gz
tcl-c40712d24f8def6f6ad3a484103fdfdba35cbf10.tar.bz2
fix 'stack grows upwards' AC_CACHE_CHECK message
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in21
1 files changed, 7 insertions, 14 deletions
diff --git a/unix/configure.in b/unix/configure.in
index fdc0f8f..9fb3a4cf 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.169 2007/11/13 16:10:29 patthoyts Exp $
+# RCS: @(#) $Id: configure.in,v 1.170 2007/11/15 04:16:26 das Exp $
AC_INIT([tcl],[8.5])
AC_PREREQ(2.59)
@@ -663,29 +663,22 @@ AC_MSG_RESULT([$tcl_ok])
# Does the C stack grow upwards or downwards? Or cross-compiling?
#--------------------------------------------------------------------
-AC_CACHE_CHECK([does the C stack grow upwards in memory?], tcl_cv_stack_grows_up, [
+AC_CACHE_CHECK([if the C stack grows upwards in memory], tcl_cv_stack_grows_up, [
AC_TRY_RUN([
- int StackGrowsUp(int *parent)
- {
+ int StackGrowsUp(int *parent) {
int here;
return (&here < parent);
}
-
- int main (int argc, char *argv[])
- {
+ int main (int argc, char *argv[]) {
int foo;
return StackGrowsUp(&foo);
}
- ],
- tcl_cv_stack_grows_up=yes,
- tcl_cv_stack_grows_up=no,
+ ], tcl_cv_stack_grows_up=yes, tcl_cv_stack_grows_up=no,
tcl_cv_stack_grows_up=unknown)])
if test $tcl_cv_stack_grows_up = unknown; then
- AC_DEFINE(TCL_CROSS_COMPILE, 1,
- [Are we cross-compiling?])
+ AC_DEFINE(TCL_CROSS_COMPILE, 1, [Are we cross-compiling?])
elif test $tcl_cv_stack_grows_up = yes; then
- AC_DEFINE(TCL_STACK_GROWS_UP, 1,
- [The C stack grows upwards in memory])
+ AC_DEFINE(TCL_STACK_GROWS_UP, 1, [The C stack grows upwards in memory.])
fi
#--------------------------------------------------------------------