summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordgp <dgp@users.sourceforge.net>2005-12-05 15:10:31 (GMT)
committerdgp <dgp@users.sourceforge.net>2005-12-05 15:10:31 (GMT)
commite424d1746c959678c7f353e1ccc1aef32317b0e4 (patch)
tree850538a1bd6cfbe2b8664c5b2d4de08daa22ea2e /unix/configure.in
parent6d30b8c11fa8b57fff54beea68c7c8394ee305d6 (diff)
downloadtcl-e424d1746c959678c7f353e1ccc1aef32317b0e4.zip
tcl-e424d1746c959678c7f353e1ccc1aef32317b0e4.tar.gz
tcl-e424d1746c959678c7f353e1ccc1aef32317b0e4.tar.bz2
2005-12-05 Don Porter <dgp@users.sourceforge.net>
*** 8.4.12 TAGGED FOR RELEASE *** * unix/configure.in: Revised fix for [Bug 1034337] from Daniel * unix/tclUnixFCmd.c: Steffen. Uses fts_*() routines. * unix/configure: autoconf-2.13 * changes: Update changes for 8.4.12 release
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 791497f..18079e9 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.21 2005/11/27 02:34:42 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.22 2005/12/05 15:10:33 dgp Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -436,6 +436,24 @@ fi
SC_ENABLE_LANGINFO
#--------------------------------------------------------------------
+# Check for support of fts functions on Darwin (readdir replacement)
+#--------------------------------------------------------------------
+
+if test "`uname -s`" = "Darwin" ; then
+ AC_CACHE_CHECK([for fts], tcl_cv_api_fts, [
+ AC_TRY_LINK([#include <sys/param.h>
+ #include <sys/stat.h>
+ #include <fts.h>],
+ [char*const p[2] = {"/", NULL};
+ FTS *f = fts_open(p, FTS_PHYSICAL|FTS_NOCHDIR|FTS_NOSTAT, NULL);
+ FTSENT *e = fts_read(f); fts_close(f);],
+ tcl_cv_api_fts=yes, tcl_cv_api_fts=no)])
+ if test $tcl_cv_api_fts = yes; then
+ AC_DEFINE(HAVE_FTS)
+ fi
+fi
+
+#--------------------------------------------------------------------
# The statements below check for systems where POSIX-style
# non-blocking I/O (O_NONBLOCK) doesn't work or is unimplemented.
# On these systems (mostly older ones), use the old BSD-style