summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2008-08-13 23:07:07 (GMT)
committerdas <das>2008-08-13 23:07:07 (GMT)
commite48a13a4a47c8dabc6edd925ae0f0d7eef67e047 (patch)
tree6627ad56f748bbe38cca117e1cbac524f91c1795 /unix/configure.in
parentedb0651e6bc56331193b87b671cf154fbb556624 (diff)
downloadtcl-e48a13a4a47c8dabc6edd925ae0f0d7eef67e047.zip
tcl-e48a13a4a47c8dabc6edd925ae0f0d7eef67e047.tar.gz
tcl-e48a13a4a47c8dabc6edd925ae0f0d7eef67e047.tar.bz2
* unix/Makefile.in: ensure Makefile shell is /bin/bash for
* unix/configure.in (SunOS): DTrace-enabled build on Solaris. (followup to 2008-06-12) [Bug 2016584]
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 1caed5e..87ea9df 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.186 2008/08/12 15:10:40 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.187 2008/08/13 23:07:07 das Exp $
AC_INIT([tcl],[8.6])
AC_PREREQ(2.59)
@@ -657,6 +657,7 @@ if test $tcl_ok = yes; then
test -z "$ac_cv_path_DTRACE" && tcl_ok=no
fi
AC_MSG_CHECKING([whether to enable DTrace support])
+MAKEFILE_SHELL='/bin/sh'
if test $tcl_ok = yes; then
AC_DEFINE(USE_DTRACE, 1, [Are we building with DTrace support?])
DTRACE_SRC="\${DTRACE_SRC}"
@@ -667,6 +668,7 @@ if test $tcl_ok = yes; then
# Need to create an intermediate object file to ensure tclDTrace.o
# gets included when linking against the static tcl library.
STLIB_LD='stlib_ld () { /usr/ccs/bin/ld -r -o $${1%.a}.o "$${@:2}" && '"${STLIB_LD}"' $${1} $${1%.a}.o ; } && stlib_ld'
+ MAKEFILE_SHELL='/bin/bash'
# Force use of Sun ar and ranlib, the GNU versions choke on
# tclDTrace.o and the combined object file above.
AR='/usr/ccs/bin/ar'
@@ -868,6 +870,7 @@ AC_SUBST(INSTALL_TZDATA)
AC_SUBST(DTRACE_SRC)
AC_SUBST(DTRACE_HDR)
AC_SUBST(DTRACE_OBJ)
+AC_SUBST(MAKEFILE_SHELL)
AC_SUBST(BUILD_DLTEST)
AC_SUBST(TCL_PACKAGE_PATH)