summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordgp <dgp@users.sourceforge.net>2002-05-31 22:20:18 (GMT)
committerdgp <dgp@users.sourceforge.net>2002-05-31 22:20:18 (GMT)
commite9decfcf415943937b04c64435f13b80941a78fb (patch)
tree7e2890810fb33260aa3268e00f8668ae59f4d326 /unix/configure.in
parent4fad013842bba77cfb05f7f123ed77ff006d8c74 (diff)
downloadtcl-e9decfcf415943937b04c64435f13b80941a78fb.zip
tcl-e9decfcf415943937b04c64435f13b80941a78fb.tar.gz
tcl-e9decfcf415943937b04c64435f13b80941a78fb.tar.bz2
* Removed internal routine
TclMathInProgress and Unix implementation of matherr(). These are now obsolete, dealing with very old versions of the C math library. Windows version is retained in case Borland compilers require it, but it is inactive. Thanks to Joe English. [Bug 474335, Patch 555635].
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in19
1 files changed, 1 insertions, 18 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 5aeba9e..7a016c4 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.86 2002/05/30 03:27:09 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.87 2002/05/31 22:20:22 dgp Exp $
AC_INIT(../generic/tcl.h)
@@ -293,23 +293,6 @@ if test $tcl_cv_union_wait = no; then
fi
#--------------------------------------------------------------------
-# Check to see whether the system supports the matherr function
-# and its associated type "struct exception".
-#--------------------------------------------------------------------
-
-AC_MSG_CHECKING([matherr support])
-AC_CACHE_VAL(tcl_cv_func_matherr,
- AC_TRY_COMPILE([#include <math.h>], [
- struct exception x;
- x.type = DOMAIN;
- x.type = SING;
- ], tcl_cv_func_matherr=yes, tcl_cv_func_matherr=no))
-AC_MSG_RESULT($tcl_cv_func_matherr)
-if test $tcl_cv_func_matherr = yes; then
- AC_DEFINE(NEED_MATHERR)
-fi
-
-#--------------------------------------------------------------------
# Check whether there is an strncasecmp function on this system.
# This is a bit tricky because under SCO it's in -lsocket and
# under Sequent Dynix it's in -linet.