summaryrefslogtreecommitdiffstats
path: root/win/configure.ac
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2021-01-05 09:19:51 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2021-01-05 09:19:51 (GMT)
commit89dbd5cedd695091e7f24d5d1c9ab54e5f333201 (patch)
tree934e2b6dd5767476f1e51be2ceba1ee39efdbf67 /win/configure.ac
parent67639babd5ddb11a2a8aa8fc065f12b38bc3d7fd (diff)
parent21e01ee4e5743f2264d5c5a6e22fec1ae44d0054 (diff)
downloadtcl-89dbd5cedd695091e7f24d5d1c9ab54e5f333201.zip
tcl-89dbd5cedd695091e7f24d5d1c9ab54e5f333201.tar.gz
tcl-89dbd5cedd695091e7f24d5d1c9ab54e5f333201.tar.bz2
Merge 8.6
Diffstat (limited to 'win/configure.ac')
-rw-r--r--win/configure.ac42
1 files changed, 19 insertions, 23 deletions
diff --git a/win/configure.ac b/win/configure.ac
index a7c2282..7000ca0 100644
--- a/win/configure.ac
+++ b/win/configure.ac
@@ -60,7 +60,6 @@ fi
AC_PROG_CC
AC_C_INLINE
-AC_HEADER_STDC
AC_CHECK_TOOL(AR, ar)
AC_CHECK_TOOL(RANLIB, ranlib)
@@ -220,17 +219,16 @@ AC_SUBST(INSTALL_MSGS)
AC_CACHE_CHECK(for FINDEX_INFO_LEVELS in winbase.h,
tcl_cv_findex_enums,
-AC_TRY_COMPILE([
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#define WIN32_LEAN_AND_MEAN
#include <windows.h>
#undef WIN32_LEAN_AND_MEAN
-],
-[
+]], [[
FINDEX_INFO_LEVELS i;
FINDEX_SEARCH_OPS j;
-],
- tcl_cv_findex_enums=yes,
- tcl_cv_findex_enums=no)
+]])],
+ [tcl_cv_findex_enums=yes],
+ [tcl_cv_findex_enums=no])
)
if test "$tcl_cv_findex_enums" = "no"; then
AC_DEFINE(HAVE_NO_FINDEX_ENUMS, 1,
@@ -241,17 +239,16 @@ fi
AC_CACHE_CHECK(for intrinsics support in compiler,
tcl_cv_intrinsics,
-AC_TRY_LINK([
+AC_LINK_IFELSE([AC_LANG_PROGRAM([[
#define WIN32_LEAN_AND_MEAN
#include <windows.h>
#undef WIN32_LEAN_AND_MEAN
#include <intrin.h>
-],
-[
+]], [[
__cpuidex(0,0,0);
-],
- tcl_cv_intrinsics=yes,
- tcl_cv_intrinsics=no)
+]])],
+ [tcl_cv_intrinsics=yes],
+ [tcl_cv_intrinsics=no])
)
if test "$tcl_cv_intrinsics" = "yes"; then
AC_DEFINE(HAVE_INTRIN_H, 1,
@@ -262,11 +259,11 @@ fi
AC_CACHE_CHECK(for wspiapi.h,
tcl_cv_wspiapi_h,
-AC_TRY_COMPILE([
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <wspiapi.h>
-], [],
- tcl_cv_wspiapi_h=yes,
- tcl_cv_wspiapi_h=no)
+]], [[]])],
+ [tcl_cv_wspiapi_h=yes],
+ [tcl_cv_wspiapi_h=no])
)
if test "$tcl_cv_wspiapi_h" = "yes"; then
AC_DEFINE(HAVE_WSPIAPI_H, 1,
@@ -279,17 +276,16 @@ fi
AC_CACHE_CHECK(for FINDEX_INFO_LEVELS in winbase.h,
tcl_cv_findex_enums,
-AC_TRY_COMPILE([
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#define WIN32_LEAN_AND_MEAN
#include <windows.h>
#undef WIN32_LEAN_AND_MEAN
-],
-[
+]], [[
FINDEX_INFO_LEVELS i;
FINDEX_SEARCH_OPS j;
-],
- tcl_cv_findex_enums=yes,
- tcl_cv_findex_enums=no)
+]])],
+ [tcl_cv_findex_enums=yes],
+ [tcl_cv_findex_enums=no])
)
if test "$tcl_cv_findex_enums" = "no"; then
AC_DEFINE(HAVE_NO_FINDEX_ENUMS, 1,