summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorwart <wart>1999-12-06 01:46:07 (GMT)
committerwart <wart>1999-12-06 01:46:07 (GMT)
commit66175fe6ed053fd5e6bc29272f33ff42404174f5 (patch)
tree3a710a3480dfb370ed98b8ae57dbf59998c4ec21 /win/configure.in
parent567d7c2cacc82b11710e8969d0bb00d68daffeee (diff)
downloadtcl-66175fe6ed053fd5e6bc29272f33ff42404174f5.zip
tcl-66175fe6ed053fd5e6bc29272f33ff42404174f5.tar.gz
tcl-66175fe6ed053fd5e6bc29272f33ff42404174f5.tar.bz2
Added "doc" target to the Makefile that will build the winhelp files
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/win/configure.in b/win/configure.in
index 7c24c20..80a5cb4 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -2,7 +2,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.14 1999/10/05 22:47:05 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.15 1999/12/06 01:46:08 wart Exp $
AC_INIT(../generic/tcl.h)
@@ -73,6 +73,13 @@ LDFLAGS=${LDFLAGS_DEFAULT}
TCL_DBGX=${DBGX}
#--------------------------------------------------------------------
+# man2tcl needs this so that it can use errno.h
+#--------------------------------------------------------------------
+
+AC_CHECK_HEADER(errno.h, , MAN2TCLFLAGS="-DNO_ERRNO_H")
+AC_SUBST(MAN2TCLFLAGS)
+
+#--------------------------------------------------------------------
# Perform final evaluations of variables with possible substitutions.
#--------------------------------------------------------------------
@@ -132,4 +139,4 @@ AC_SUBST(LIBRARIES)
AC_SUBST(MAKE_LIB)
AC_SUBST(MAKE_DLL)
-AC_OUTPUT(Makefile tclConfig.sh)
+AC_OUTPUT(Makefile tclConfig.sh tcl.hpj)