summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2003-01-13 01:27:50 (GMT)
committermdejong <mdejong>2003-01-13 01:27:50 (GMT)
commit6638ab2cc75d41465a5191828f2c9acbab86af6b (patch)
tree4181938d9b16505f540d6023e6d4474966db168f /win/configure.in
parent73064e4b76a9357a6054724dc8dda93a6fec52e9 (diff)
downloadtcl-6638ab2cc75d41465a5191828f2c9acbab86af6b.zip
tcl-6638ab2cc75d41465a5191828f2c9acbab86af6b.tar.gz
tcl-6638ab2cc75d41465a5191828f2c9acbab86af6b.tar.bz2
* win/configure: Regen.
* win/configure.in: Check for typedefs like LPFN_ACCEPT in winsock2.h and define HAVE_NO_LPFN_DECLS if not found. * win/tclWinSock.c: Define LPFN_* typedefs if HAVE_NO_LPFN_DECLS is defined. This fixes the build under Mingw and Cygwin, it was broken by the changes made on 2002-11-26.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in25
1 files changed, 24 insertions, 1 deletions
diff --git a/win/configure.in b/win/configure.in
index d580a63..9dfaebe 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.60 2002/12/13 17:46:01 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.61 2003/01/13 01:27:51 mdejong Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -146,6 +146,29 @@ if test "$tcl_cv_eh_disposition" = "no" ; then
[Defined when cygwin/mingw does not support EXCEPTION DISPOSITION])
fi
+
+# Check to see if the winsock2.h include file provided contains
+# typedefs like LPFN_ACCEPT and friends.
+#
+AC_CACHE_CHECK(for LPFN_ACCEPT support in winsock2.h,
+ tcl_cv_lpfn_decls,
+AC_TRY_COMPILE([
+#define WIN32_LEAN_AND_MEAN
+#include <windows.h>
+#undef WIN32_LEAN_AND_MEAN
+#include <winsock2.h>
+],
+[
+ LPFN_ACCEPT accept;
+],
+ tcl_cv_lpfn_decls=yes,
+ tcl_cv_lpfn_decls=no)
+)
+if test "$tcl_cv_lpfn_decls" = "no" ; then
+ AC_DEFINE(HAVE_NO_LPFN_DECLS, 1,
+ [Defined when cygwin/mingw does not support LPFN_ACCEPT and friends.])
+fi
+
#--------------------------------------------------------------------
# Determines the correct binary file extension (.o, .obj, .exe etc.)
#--------------------------------------------------------------------