summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2001-11-07 23:37:52 (GMT)
committermdejong <mdejong>2001-11-07 23:37:52 (GMT)
commit8f77862259393dc45b717b5271852458f33c2fad (patch)
tree3b8a35efc9dbc4a378d4f1d5cb90d26d85bf60e0 /win/configure.in
parent513d743d0f05094ff7985f9840cc5db7f4bb3955 (diff)
downloadtcl-8f77862259393dc45b717b5271852458f33c2fad.zip
tcl-8f77862259393dc45b717b5271852458f33c2fad.tar.gz
tcl-8f77862259393dc45b717b5271852458f33c2fad.tar.bz2
* win/README: Change minimum VC++ version to 5.X since
4.X is known not to work. Indicate that Mingw is required and building with Cygwin gcc is not supported. Include instructions that indicate how to install Mingw and what URLs folks should use to download the supported version of Mingw. * win/configure: Regen. * win/configure.in: Error out if user tries to compile the Windows version of Tcl with Cygwin gcc. Users should compile with Mingw gcc instead.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/win/configure.in b/win/configure.in
index fd07348..7ab1973 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.43 2001/10/15 21:53:46 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.44 2001/11/07 23:37:52 mdejong Exp $
AC_INIT(../generic/tcl.h)
@@ -71,11 +71,16 @@ fi
AC_PROG_MAKE_SET
#--------------------------------------------------------------------
-# These two macros perform additinal compiler test.
+# Perform additinal compiler tests.
#--------------------------------------------------------------------
AC_CYGWIN
+if test "$ac_cv_cygwin" = "yes" ; then
+ AC_MSG_ERROR([Compiling with the Cygwin version of gcc is not supported.
+ Use the Mingw version of gcc from www.mingw.org instead.])
+fi
+
#--------------------------------------------------------------------
# Determines the correct binary file extension (.o, .obj, .exe etc.)
#--------------------------------------------------------------------