summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorsurles <surles>1999-06-02 19:29:19 (GMT)
committersurles <surles>1999-06-02 19:29:19 (GMT)
commitb5c1be6c9518d4655a3e2ec49653ca6c98d95e4d (patch)
tree531f7c9a0dace00b0d3c7878d8efe81a08c1d3b0 /win/configure.in
parentacdb8dd7bf31d77895449736e6d7e8d3417e288e (diff)
downloadtcl-b5c1be6c9518d4655a3e2ec49653ca6c98d95e4d.zip
tcl-b5c1be6c9518d4655a3e2ec49653ca6c98d95e4d.tar.gz
tcl-b5c1be6c9518d4655a3e2ec49653ca6c98d95e4d.tar.bz2
Added makefile targets and configure switches to be TEA compliant
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in37
1 files changed, 32 insertions, 5 deletions
diff --git a/win/configure.in b/win/configure.in
index 88dcd22..bee34e0 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -2,7 +2,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tcl.h)
-# RCS: @(#) $Id: configure.in,v 1.1 1999/05/28 23:02:44 stanton Exp $
+# RCS: @(#) $Id: configure.in,v 1.2 1999/06/02 19:29:20 surles Exp $
TCL_VERSION=8.1
TCL_MAJOR_VERSION=8
@@ -10,6 +10,19 @@ TCL_MINOR_VERSION=1
TCL_PATCH_LEVEL=.2
VERSION=${TCL_VERSION}
+# Check whether --enable-gcc or --disable-gcc was given. Do this before
+# AC_PROG_CC and AC_CYGWIN are called so the compiler can be fully tested
+# by built-in autoconf tools.
+
+AC_ARG_ENABLE(gcc, [ --enable-gcc build with gcc],
+ [tcl_ok=$enableval], [tcl_ok=test_all])
+if test "$tcl_ok" = "yes"; then
+ CC=gcc
+fi
+if test "$tcl_ok" = "no"; then
+ CC=cl
+fi
+
AC_PROG_MAKE_SET
AC_PROG_CC
AC_CYGWIN
@@ -24,16 +37,29 @@ if test "$tcl_ok" = "yes"; then
CFLAGS='${CFLAGS_DEBUG}'
LD_FLAGS='${LDFLAGS_DEBUG}'
TCL_DBGX=d
+ echo "building with debug symbols"
else
CFLAGS='${CFLAGS_OPTIMIZE}'
LD_FLAGS='${LDFLAGS_OPTIMIZE}'
TCL_DBGX=""
+ echo "building without debug symbols"
fi
# Trick to replace DBGX with TCL_DBGX
DBGX='${TCL_DBGX}'
eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
+# Check whether --enable-threads or --disable-threads was given.
+
+AC_ARG_ENABLE(threads, [ --enable-threads build with threads],
+ [tcl_ok=$enableval], [tcl_ok=no])
+if test "$tcl_ok" = "yes"; then
+ AC_DEFINE(TCL_THREADS)
+ echo "building with threads enabled"
+else
+ echo "building with threads disabled (default)"
+fi
+
#--------------------------------------------------------------------
# The statements below define a collection of symbols related to
# building libtcl as a shared library instead of a static library.
@@ -79,9 +105,9 @@ else
MAKE_LIB="\${AR} -out:\$@"
MAKE_EXE="\${CC} -Fe\$@"
- echo "TCL_SHARED_BUILD=${TCL_SHARED_BUILD}"
if test "${TCL_SHARED_BUILD}" = "0" ; then
# static
+ echo "building static version"
runtime=-MT
MAKE_DLL="echo "
LIBSUFFIX="s\${TCL_DBGX}.lib"
@@ -90,6 +116,7 @@ else
DLLSUFFIX=""
else
# dynamic
+ echo "building dynamic version"
runtime=-MD
MAKE_DLL="\${SHLIB_LD} \${SHLIB_LD_LIBS} -out:\$@"
LIBSUFFIX="\${TCL_DBGX}.lib"
@@ -98,9 +125,9 @@ else
LIBRARIES="\${SHARED_LIBRARIES}"
fi
- EXTRA_CFLAGS="-YX -nologo"
- CFLAGS_DEBUG="-Z7 -Od -WX ${runtime}d"
- CFLAGS_OPTIMIZE="-O2 -Gs -GD ${runtime}"
+ EXTRA_CFLAGS="-YX"
+ CFLAGS_DEBUG="-nologo -Z7 -Od -WX ${runtime}d"
+ CFLAGS_OPTIMIZE="-nologo -O2 -Gs -GD ${runtime}"
CFLAGS_WARNING="-W3"
LDFLAGS_DEBUG="-debug"
LDFLAGS_OPTIMIZE="-release"