summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authordkf <donal.k.fellows@manchester.ac.uk>2008-12-18 15:36:45 (GMT)
committerdkf <donal.k.fellows@manchester.ac.uk>2008-12-18 15:36:45 (GMT)
commitc61d3b006e4c4629bdd8962d0eb9c3f3596e539f (patch)
treec40a71f512b9838fab19265a1f9e03b9ce39e51c /win/configure.in
parent9f2870c4a88fbae81e4e09882e9cc91bcfea6038 (diff)
downloadtcl-c61d3b006e4c4629bdd8962d0eb9c3f3596e539f.zip
tcl-c61d3b006e4c4629bdd8962d0eb9c3f3596e539f.tar.gz
tcl-c61d3b006e4c4629bdd8962d0eb9c3f3596e539f.tar.bz2
Try to do the wizardry again...
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in22
1 files changed, 4 insertions, 18 deletions
diff --git a/win/configure.in b/win/configure.in
index a057344..92b28ce 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.111 2008/12/14 13:32:11 dkf Exp $
+# RCS: @(#) $Id: configure.in,v 1.112 2008/12/18 15:36:45 dkf Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.59)
@@ -337,25 +337,11 @@ SC_TCL_CFG_ENCODING
SC_ENABLE_SHARED
#------------------------------------------------------------------------
-# Add stuff for zlib
+# Add stuff for zlib; note that this is mostly done in the makefile now
+# as we just assume that the platform hasn't got a usable z.lib
#------------------------------------------------------------------------
-tcl_ok=yes
-AC_CHECK_HEADER([zlib.h],[
- AC_CHECK_TYPE([gz_header],[],[
- tcl_ok=no
- AC_MSG_WARN([todo: Add -Icompat/zlib/include to compile lines])
- ],[#include <zlib.h>])],[
- tcl_ok=no
- AC_MSG_WARN([todo: Add -Icompat/zlib/include to compile lines])
- ])
-AS_IF([test $tcl_ok = yes], [
- AC_SEARCH_LIBS([deflateSetHeader],[z Z zlib Zlib ZLIB],[],[
- tcl_ok=no
- AC_MSG_WARN([todo: Add compat/zlib to list of things to build])
- ])])
-AS_IF([test $tcl_ok = yes], [
- AC_DEFINE(HAVE_ZLIB, 1, [Is there an installed zlib?])])
+AC_DEFINE(HAVE_ZLIB, 1, [Is there an installed zlib?])
#--------------------------------------------------------------------
# The statements below define a collection of compile flags. This