summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorwart <wart>1999-06-10 21:47:28 (GMT)
committerwart <wart>1999-06-10 21:47:28 (GMT)
commitde0c1b2baff8a335c56d015f9c53e82d13c99ca3 (patch)
tree81519c286863ec56be85b6928f348e6da071d233 /win/configure.in
parentc02e24e314d8d55fbe6d6bdb3237275262101497 (diff)
downloadtcl-de0c1b2baff8a335c56d015f9c53e82d13c99ca3.zip
tcl-de0c1b2baff8a335c56d015f9c53e82d13c99ca3.tar.gz
tcl-de0c1b2baff8a335c56d015f9c53e82d13c99ca3.tar.bz2
Modified configure.in that uses the tcl.m4 macros
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in56
1 files changed, 9 insertions, 47 deletions
diff --git a/win/configure.in b/win/configure.in
index 6cfbea2..f4e1e5c 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -2,7 +2,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tcl.h)
-# RCS: @(#) $Id: configure.in,v 1.3 1999/06/05 00:18:13 stanton Exp $
+# RCS: @(#) $Id: configure.in,v 1.4 1999/06/10 21:47:28 wart Exp $
TCL_VERSION=8.1
TCL_MAJOR_VERSION=8
@@ -14,13 +14,7 @@ VERSION=${TCL_VERSION}
# AC_PROG_CC and AC_CYGWIN are called so the compiler can be fully tested
# by built-in autoconf tools.
-AC_ARG_ENABLE(gcc, [ --enable-gcc build with gcc],
- [tcl_ok=$enableval], [tcl_ok=no])
-if test "$tcl_ok" = "yes"; then
- CC=gcc
-else
- CC=cl
-fi
+SC_ENABLE_GCC
AC_PROG_MAKE_SET
AC_PROG_CC
@@ -30,19 +24,11 @@ AC_EXEEXT
# Set the default compiler switches based on the --enable-symbols option
-AC_ARG_ENABLE(symbols, [ --enable-symbols build with debugging symbols],
- [tcl_ok=$enableval], [tcl_ok=no])
-if test "$tcl_ok" = "yes"; then
- CFLAGS='${CFLAGS_DEBUG}'
- LD_FLAGS='${LDFLAGS_DEBUG}'
- TCL_DBGX=d
- echo "building with debug symbols"
-else
- CFLAGS='${CFLAGS_OPTIMIZE}'
- LD_FLAGS='${LDFLAGS_OPTIMIZE}'
- TCL_DBGX=""
- echo "building without debug symbols"
-fi
+SC_ENABLE_SYMBOLS
+
+CFLAGS=${CFLAGS_DEFAULT}
+LD_FLAGS=${LDFLAGS_DEFAULT}
+TCL_DBGX=${DBGX}
# Trick to replace DBGX with TCL_DBGX
DBGX='${TCL_DBGX}'
@@ -50,38 +36,14 @@ eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
# Check whether --enable-threads or --disable-threads was given.
-AC_ARG_ENABLE(threads, [ --enable-threads build with threads],
- [tcl_ok=$enableval], [tcl_ok=no])
-if test "$tcl_ok" = "yes"; then
- AC_DEFINE(TCL_THREADS)
- echo "building with threads enabled"
-else
- echo "building with threads disabled (default)"
-fi
+SC_ENABLE_THREADS
#--------------------------------------------------------------------
# The statements below define a collection of symbols related to
# building libtcl as a shared library instead of a static library.
#--------------------------------------------------------------------
-AC_ARG_ENABLE(shared,
- [ --enable-shared build libtcl as a shared library (on by default)],
- [tcl_ok=$enableval], [tcl_ok=yes])
-
-# Check whether --enable-shared or --disable-shared was given.
-if test "${enable_shared+set}" = set; then
- enableval="$enable_shared"
- tcl_ok=$enableval
-else
- tcl_ok=yes
-fi
-
-if test "$tcl_ok" = "yes" ; then
- TCL_SHARED_BUILD=1
-else
- TCL_SHARED_BUILD=0
- AC_DEFINE(STATIC_BUILD)
-fi
+SC_ENABLE_SHARED
EXTRA_CFLAGS=""
# set various compiler flags depending on whether we are using gcc or cl