summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 7d803b2..b2e8f70 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.120 2004/11/18 00:45:03 rmax Exp $
+# RCS: @(#) $Id: configure.in,v 1.121 2004/11/19 06:28:31 das Exp $
AC_INIT([tcl],[8.5])
AC_PREREQ(2.57)
@@ -497,6 +497,7 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
TCL_BUILD_LIB_SPEC="-F`pwd` -framework Tcl"
TCL_LIB_SPEC="-framework Tcl"
TCL_LIB_FILE="Tcl"
+ AC_DEFINE(TCL_FRAMEWORK, 1, [Is Tcl built as a framework?]))
elif test "$SHARED_BUILD" = "0" || test "$TCL_NEEDS_EXP_FILE" = "0"; then
if test "${TCL_LIB_VERSIONS_OK}" = "ok"; then
TCL_LIB_FLAG="-ltcl${TCL_VERSION}\${TCL_DBGX}"