summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 682e5e1..1d90e39 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.92 2002/07/19 20:29:47 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.93 2002/07/24 13:51:18 das Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -428,6 +428,9 @@ else
TCL_SHLIB_CFLAGS=""
eval "TCL_LIB_FILE=libtcl${TCL_UNSHARED_LIB_SUFFIX}"
MAKE_LIB="\${STLIB_LD} \[$]@ \${OBJS}"
+ if test "x$DL_OBJS" = "xtclLoadDyld.o"; then
+ MAKE_LIB="${MAKE_LIB} ; \${RANLIB} \$@"
+ fi
fi
# tclConfig.sh needs a version of the _LIB_SUFFIX that has been eval'ed