summaryrefslogtreecommitdiffstats
path: root/generic/tclCompCmds.c
Commit message (Expand)AuthorAgeFilesLines
* merge trunkmig2013-01-031-4/+4
|\
| * All tests pass except one; not sure what's wrong there.dkf2013-01-021-4/+4
* | merge trunkmig2012-11-261-287/+2332
|\ \ | |/
| * Added compilation of [array exists], [array set] and [array unset]. Fixed a w...merge_to_trunkdkf2012-11-051-22/+257
| * Added compilation of [string last] and improved the compilation of [string ra...dkf2012-11-031-0/+73
| * Added compilation of [info object isa object] (i.e., object verification).dkf2012-11-031-0/+36
| * Added more TclOO introspection bytecodes ([info object class], [info object n...dkf2012-11-021-0/+40
| * Added compilation of [dict create] and [dict merge].dkf2012-11-011-2/+205
| * Added [dict exists] compilation; implementation is 95% shared with [dict get].dkf2012-10-301-0/+36
| * Added compilation of [regsub] (in the simplest, most restricted case).dkf2012-10-301-0/+174
| * Minor: correct a commentdkf2012-10-291-2/+3
| * Compiler for some of the simpler cases of [format].dkf2012-10-291-0/+219
| * Compilation of [info commands] in the case of a fully-qualified literal name.dkf2012-10-291-0/+58
| * Added [self namespace] to bytecoded command set.dkf2012-10-281-5/+34
| * Compile [namespace which -command]; big performance saving in some contexts.dkf2012-10-261-0/+46
| * Added compilation of [namespace code] (except for gnarly edge cases).dkf2012-10-251-0/+50
| * merge trunkdkf2012-10-241-0/+61
| |\
| | * Added compilation of [dict unset]; the bytecode needed already existed anyway.dkf2012-10-241-0/+61
| * | yet another small introspector: [self]dkf2012-10-191-0/+34
| * | merge trunkdkf2012-10-171-8/+183
| |\ \ | | |/
| | * ...and all the compilation and tests now work/passtip_votedkf2012-10-051-23/+32
| | * compilation code adjusteddkf2012-10-051-69/+73
| | * Rename 'mapeach' to 'lmap' per preferred alternative in TIP #405.twylite2012-08-081-5/+5
| | * Back-out 'foreacha' implementation but leave code cleanup of 'mapeach' and 'd...twylite2012-08-081-21/+2
| | * [Patch-3163961] Implementation of TIP #405 merged from private branch. Inclu...twylite2012-08-031-8/+189
| * | merge trunkdkf2012-08-041-2/+2
| |\ \ | | |/
| | * Factor out a number of common patterns of use of Tcl_DStringAppend.dkf2012-07-031-2/+2
| * | Compilation of misc info sometimes used in high-performance code.dkf2012-03-041-8/+94
| |/
| * * generic/tclCompCmds.c (TclCompileLreplaceCmd): Added a compilationdkf2012-02-151-0/+124
| * * generic/tclCompCmds.c (TclCompileLrangeCmd): Add compiler fordkf2012-02-151-3/+110
| * * generic/tclCompCmds.c (TclCompileDictForCmd): [Bug 3487626]: Fixdkf2012-02-151-1/+2
| |\
| | * * generic/tclCompCmds.c (TclCompileDictForCmd): [Bug 3487626]: Fixdkf2012-02-151-1/+2
| | * 3485022 Disable ensemble subcommand compile inside a Tcl_Create*Trace().dgp2012-02-061-1/+2
| | * 3485022 TclCompileEnsemble() avoid compile when exec traces set.dgp2012-02-061-1/+2
| | |\
| | * | Drop old code.dgp_switch_compiledgp2011-05-021-155/+2
| | * | Revised TclFindElement() interface.dgp2011-05-021-14/+5
| | |\ \
| | * \ \ Replace TclCountSpaceRuns() with TclMaxListLength() which is the function wedgp2011-05-021-13/+2
| | |\ \ \ | | | |/ /
| | * | | Tighten up the patch.dgp2011-05-021-13/+16
| | * | | Rewrite of parts of the [switch] compiler to better use the powers ofdgp2011-04-281-3/+104
| | |/ /
| * | | Minor: make comments accurate in [catch] compiler.dkf2012-01-301-22/+22
| * | | * generic/tclCompCmds.c (TclCompileCatchCmd): Added a more efficientdkf2012-01-301-1/+29
| * | | * generic/tclCompCmds.c (TclCompileDictWithCmd): Corrected handling ofdkf2011-10-091-303/+312
| * | | Added support for having the dict var itself referenced by LVT index.dkf2011-10-031-14/+55
| * | | Experimental compilation of the [dict with] subcommand. No tests yet, and notdkf2011-10-021-0/+179
* | | | merge trunkmig2011-09-281-1/+1
|\ \ \ \ | |/ / /
| * | | [Bug 3386417] avoid a reference loop between the bytecode and its companion e...ferrieux2011-08-091-1/+1
* | | | development branch for allocator changesmig2011-03-181-14/+12
|/ / /
* | | Adjust ckalloc/ckfree macros to greatly reduce number of explicit casts indkf2011-03-121-19/+18
* | | Turn namespace into an ensemble. Not yet on trunk because of some mysterious ...dkf2011-03-091-16/+7
* | | Now that we're no longer using SCM based on RCS, the RCS Keyword linesdgp2011-03-021-2/+0
|\ \ \ | |/ /