summaryrefslogtreecommitdiffstats
path: root/generic/tclObj.c
Commit message (Collapse)AuthorAgeFilesLines
* Make mp_get_long and mp_set_long available to tommath-enabled Tcl ↵jan.nijtmans2017-09-131-3/+3
| | | | extensions. Deprecate the internal TclBNInitBignumFrom* functions, in favor of the official tommath functions with the same purpose.
* Remove some unnecessary "struct" definitions and some type casts no longer ↵jan.nijtmans2017-04-111-1/+1
| | | | necessary. No functional changes.
* Since Tcl_AppendPrintfToObj() now understands the %p format, we can use it. ↵jan.nijtmans2017-03-311-10/+11
| | | | Eliminating some internal string buffers.
* If compiled with TCL_NO_DEPRECATED, remove some more stub entries which are ↵jan.nijtmans2017-03-201-1/+1
| | | | not used any more.
* Eliminate internal use of ↵jan.nijtmans2017-03-131-5/+7
| | | | TclNewBooleanObj()/TclSetBooleanObj()/TclSetIntObj(). Replace Tcl_DbNewBooleanObj() with trivial macro.
* More internal use of size_t in stead of int, e.g. for epoch'sjan.nijtmans2017-02-151-3/+3
|
* In TclGetNumberFromObj() macro (tclExecute.c): Don't fill in type if ↵jan.nijtmans2017-02-031-3/+2
| | | | | TCL_ERROR is returned: The caller doesn't do anything with this. Don't access (non-const) variable tclEmptyStringRep any more, use its value (&tclEmptyString) directly. Only keep it in tclPkg.c, for error checking.
* Update documentation on recent changes in Tcl_LinkVar.jan.nijtmans2017-01-311-4/+4
|\ | | | | Minor code clean-up. No functional changes.
| * Update documentation on recent changes in Tcl_LinkVar.jan.nijtmans2017-01-311-6/+6
| | | | | | | | Don't use TCL_NO_DEPRECATED for disabling tests-cases: Those were not deprecated in 8.6 yet. Minor code clean-up. No functional changes.
* | Some code cleanup: More internal use of size_t, less type casts (because of ↵jan.nijtmans2017-01-271-8/+9
| | | | | | | | this). No functional changes.
* | Eliminate the internal macro/function TclNewIntObj: In all cases ↵jan.nijtmans2016-12-231-2/+2
| | | | | | | | TclNewLongObj is just as good.
* | More internal use of size_t in stead of int.jan.nijtmans2016-11-211-3/+3
| |
* | Fix libtommath's mp_radix_size() function such that it returns 2 for ↵jan.nijtmans2016-11-171-5/+3
|\ \ | |/ | | | | single-digit numbers. Add testcases for mp_radix_size() and mp_iseven(). Undo useless change in bn_mp_add_d.c (bring back libtommath's version).
| * Fix libtommath's mp_radix_size() function such that it returns 2 for ↵jan.nijtmans2016-11-171-5/+3
| |\ | | | | | | | | | single-digit numbers. Add testcases for mp_radix_size() and mp_iseven(). Undo useless change in bn_mp_add_d.c (bring back libtommath's version).
| | * Fix libtommath's mp_radix_size() function such that it returns 2 for ↵jan.nijtmans2016-11-171-5/+3
| | | | | | | | | | | | single-digit numbers. Add testcases for mp_radix_size() and mp_iseven(). Undo useless change in bn_mp_add_d.c (bring back libtommath's version).
| | * Eliminate a few gcc compiler warnings, when using -Wwrite-strings (tested ↵jan.nijtmans2015-10-011-21/+21
| | | | | | | | | | | | with the brand-new gcc 5.2.0)
* | | Fix [d4e7780ca1681cd095dbd81fe264feff75c988f7|d4e7780ca1]: "global" cmd ↵jan.nijtmans2016-09-071-1/+6
|\ \ \ | |/ / | | | | | | literal sharing vs. per-interp resolvers
| * | Additiona patch/suggestion from Gustaf. This indeed fixes the crash in ↵bug_d4e7780ca1jan.nijtmans2016-09-061-1/+1
| | | | | | | | | | | | oo.test. Looks good to me, so only waiting for final feedback from Gustaf and eventually feedback from other people.
| * | some more clean-upjan.nijtmans2016-09-051-7/+5
| | |
| * | Proposed patch for [d4e7780ca1681cd095dbd81fe264feff75c988f7|d4e7780ca1], by ↵jan.nijtmans2016-09-021-2/+7
| | | | | | | | | | | | Gustaf Neumann
* | | [0363f0146c] Fix [array startsearch] id handling to support var name variationsdgp2016-07-191-1/+0
| | |
* | | Factor the cmdName intrep setting code into common utility routine.dgp2016-07-151-75/+63
| | |
* | | Stop using the tclCmdNameType to store failed command lookups. If we don'tdgp2016-07-151-14/+11
| | | | | | | | | find a command, there's nothing to store, so better not to shimmer at all.
* | | One of the validity checks for the "cmdName" type is to see if thedgp2016-07-151-1/+0
| | | | | | | | | | | | | | | | | | | | | | | | resolved command has been deleted by checking for the CMD_IS_DELETED flag. Only one thing sets this flag -- Tcl_DeleteCommandFromToken(), and every time it sets that flag it also bumps the cmdEpoch of the Command as well. The "cmdName" type is already validating that epoch. It gains nothing to be checking the CMD_IS_DELETED flag too. Eliminated the pointless test.
* | | Make hash type changable by compiling with -DTCL_HASH_TYPE=size_t (for ↵jan.nijtmans2016-07-121-2/+2
| | | | | | | | | | | | example). Default (unsigned) cannot be changed in Tcl 8.x, that must wait until Tcl 9.
* | | Micro-optimization: Use TclGetStringFromObj in stead of Tcl_GetStringFromObj ↵jan.nijtmans2016-07-081-2/+2
| | | | | | | | | | | | in many places where possible.
* | | Fix [07d13d99b0a9]: Who broke TCL 8.6 and Tclblend ?jan.nijtmans2016-04-101-2/+3
|\ \ \ | |/ /
| * | Fix [07d13d99b0a9]: Who broke TCL 8.6 and Tclblend ?jan.nijtmans2016-04-101-2/+3
|/ /
* | typo in comment. Eliminate unnecessary end-of-line spacing.jan.nijtmans2015-10-191-2/+2
| |
* | micro-opt of hash lookups found by drhMiguel Sofer2015-09-221-6/+5
| |
* | Revert refcount changes that were not cosmetic.dgp2015-07-021-2/+2
| | | | | | | | | | | | Changing equality testing to inequality testing does more than make code prettier or clearer. It makes it less strict, and thus more tolerant of other bugs elsewhere. Such changes deserve separate consideration at least, not breezy entry in an otherwise "code cleanup" commit.
* | Consistancy in refcount management.jan.nijtmans2015-06-301-3/+3
| |
* | Use twoPtrValue in stead of ptrAndLongRep for implementation of some ↵jan.nijtmans2015-06-301-16/+15
| | | | | | | | | | internal Obj types. On most platforms this doesn't make a difference, as (void *) and (long) generially have the same size. The only exception where it makes a difference is win64, as we can now store 64 bits in this field in stead of only 32 bits, exactly what the processor is optimized for.
* | Make tweak to the mem-debug tracking official. It is now again possible to ↵andreask2015-05-271-14/+33
|\ \ | |/ | | | | use regular packages with a mem-debug core without inciting a panic.
| * Make tweak to the mem-debug tracking official. It is now again possible to ↵andreask2015-05-271-14/+33
| |\ | | | | | | | | | use regular packages with a mem-debug core without inciting a panic.
| | * Minor compilation issue fix, make sure variable declaration (via macro) is ↵aku_mem_debug_allow_regularJoe Mistachkin2015-05-221-6/+7
| | | | | | | | | | | | first.
| | * Moved Tcl_Obj* objThreadMap release tracking to a location where regular ↵andreask2015-05-221-14/+32
| | | | | | | | | | | | packages will call through, enabling their full tracking by the core, and thus avoiding the "expected to create new entry for object map" panic seen otherwise.
* | | Remove Tcl_Preserve support for ContLineLoc values. It's not needed.dgp2013-08-071-35/+3
| | | | | | | | | This allows the clLoc field of CompileEnv struct to go away too.
* | | Implement Tcl_NewBooleanObj, Tcl_DbNewBooleanObj and Tcl_SetBooleanObj as ↵jan.nijtmans2013-04-231-17/+17
|\ \ \ | |/ / | | | | | | | | | | | | macros using Tcl_NewIntObj, Tcl_DbNewLongObj and Tcl_SetIntObj. Starting with Tcl 8.5, this is exactly the same, it only eliminates code duplication. Eliminate use of NO_WIDE_TYPE everywhere: It's exactly the same as TCL_WIDE_INT_IS_LONG
| * | Implement Tcl_NewBooleanObj, Tcl_DbNewBooleanObj and Tcl_SetBooleanObj as ↵jan.nijtmans2013-04-231-4/+6
| |/ | | | | | | | | macros using Tcl_NewIntObj, Tcl_DbNewLongObj and Tcl_SetIntObj. Starting with Tcl 8.5, this is exactly the same, it only eliminates code duplication.
* | Greater protection against double TclFreeObj() calls in TCL_MEM_DEBUG mode.dgp2013-03-111-0/+12
|\ \ | |/
| * Greater protection against double TclFreeObj() calls in TCL_MEM_DEBUG mode.dgp2013-03-111-0/+12
| |
* | Allow Tcl to be compiled even if Tcl_Eval, Tcl_GetVar, ... are macros.jan.nijtmans2013-02-281-2/+5
| |
* | Don't panic if Tcl_ConvertToType is called for a type that doesn't have a ↵jan.nijtmans2013-02-261-1/+6
|\ \ | |/ | | | | setFromAnyProc, create a proper error message.
| * Don't panic if Tcl_ConvertToType is called for a type that doesn't have a ↵jan.nijtmans2013-02-261-1/+6
| | | | | | | | setFromAnyProc, create a proper error message.
* | Eliminate all Tcl_ConvertToType calls and all direct calls to ↵jan.nijtmans2013-02-041-7/+6
| | | | | | | | typePtr->setFromAnyProc (except the call from inside the Tcl_ConvertToType function) from the Tcl core.
* | merge core-8-5-branchjan.nijtmans2013-01-311-3/+3
|\ \ | |/
| * Use twoPtrValue.ptr1 in stead of otherValuePtr everywhere. This is exactly ↵jan.nijtmans2013-01-311-3/+3
| | | | | | | | the same field, but it allows twoPtrValue.ptr2 to be used for other purposes.
| * Backport fix for [Bug 2857044].dgp2011-04-271-0/+1
| |
* | more result generation conversiondkf2012-08-041-21/+21
| |