summaryrefslogtreecommitdiffstats
path: root/unix/configure.ac
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2021-01-29 10:54:46 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2021-01-29 10:54:46 (GMT)
commit1ee8159bc5bdcbf5785cab15202d946f861a2fd1 (patch)
treea97ffd53b08443aa17ac6812eb371b19c8075aaf /unix/configure.ac
parenta8e2e4df7ffb5875c42ccaaa949f3fb2325a94b8 (diff)
parentb54ff1e8095404452e267a28ca9a5caea01a5153 (diff)
downloadtk-1ee8159bc5bdcbf5785cab15202d946f861a2fd1.zip
tk-1ee8159bc5bdcbf5785cab15202d946f861a2fd1.tar.gz
tk-1ee8159bc5bdcbf5785cab15202d946f861a2fd1.tar.bz2
Merge trunk. More progress: In shared builds, Tk zip-files are now appended to the Tk shared library
Diffstat (limited to 'unix/configure.ac')
-rw-r--r--unix/configure.ac90
1 files changed, 45 insertions, 45 deletions
diff --git a/unix/configure.ac b/unix/configure.ac
index 1b1b7b4..5a3b813 100644
--- a/unix/configure.ac
+++ b/unix/configure.ac
@@ -545,51 +545,6 @@ fi
AC_C_CHAR_UNSIGNED
#--------------------------------------------------------------------
-# Zipfs support - Tip 430
-#--------------------------------------------------------------------
-AC_ARG_ENABLE(zipfs,
- AS_HELP_STRING([--enable-zipfs],[build with Zipfs support (default: on)]),
- [tcl_ok=$enableval], [tcl_ok=yes])
-if test "$tcl_ok" = "yes" ; then
- #
- # Find a native compiler
- #
- AX_CC_FOR_BUILD
- #
- # Find a native zip implementation
- #
- SC_ZIPFS_SUPPORT
- ZIPFS_BUILD=1
- TK_ZIP_FILE=libtk_${TK_MAJOR_VERSION}_${TK_MINOR_VERSION}_${TK_PATCH_LEVEL}.zip
-else
- ZIPFS_BUILD=0
- TK_ZIP_FILE=
-fi
-# Do checking message here to not mess up interleaved configure output
-AC_MSG_CHECKING([for building with zipfs])
-if test "${ZIPFS_BUILD}" = 1; then
- if test "${SHARED_BUILD}" = 0; then
- ZIPFS_BUILD=2;
- AC_DEFINE(ZIPFS_BUILD, 2, [Are we building with zipfs enabled?])
- INSTALL_LIBRARIES=install-libraries-zipfs-static
- AC_MSG_RESULT([yes])
- else
- AC_DEFINE(ZIPFS_BUILD, 1, [Are we building with zipfs enabled?])\
- INSTALL_LIBRARIES=install-libraries-zipfs-shared
- AC_MSG_RESULT([yes])
- fi
-else
-AC_MSG_RESULT([no])
-INSTALL_LIBRARIES=install-libraries
-INSTALL_MSGS=install-msgs
-fi
-AC_SUBST(ZIPFS_BUILD)
-AC_SUBST(TK_ZIP_FILE)
-AC_SUBST(INSTALL_LIBRARIES)
-AC_SUBST(INSTALL_MSGS)
-
-
-#--------------------------------------------------------------------
# The statements below define a collection of symbols related to
# building libtk as a shared library instead of a static library.
#--------------------------------------------------------------------
@@ -708,6 +663,51 @@ else
fi
#--------------------------------------------------------------------
+# Zipfs support - Tip 430
+#--------------------------------------------------------------------
+AC_ARG_ENABLE(zipfs,
+ AS_HELP_STRING([--enable-zipfs],[build with Zipfs support (default: on)]),
+ [tcl_ok=$enableval], [tcl_ok=yes])
+if test "$tcl_ok" = "yes" -a "x$enable_framework" != "xyes"; then
+ #
+ # Find a native compiler
+ #
+ AX_CC_FOR_BUILD
+ #
+ # Find a native zip implementation
+ #
+ SC_ZIPFS_SUPPORT
+ ZIPFS_BUILD=1
+ TK_ZIP_FILE=libtk_${TK_MAJOR_VERSION}_${TK_MINOR_VERSION}_${TK_PATCH_LEVEL}.zip
+else
+ ZIPFS_BUILD=0
+ TK_ZIP_FILE=
+fi
+# Do checking message here to not mess up interleaved configure output
+AC_MSG_CHECKING([for building with zipfs])
+if test "${ZIPFS_BUILD}" = 1; then
+ if test "${SHARED_BUILD}" = 0; then
+ ZIPFS_BUILD=2;
+ AC_DEFINE(ZIPFS_BUILD, 2, [Are we building with zipfs enabled?])
+ INSTALL_LIBRARIES=install-libraries-zipfs-static
+ AC_MSG_RESULT([yes])
+ else
+ AC_DEFINE(ZIPFS_BUILD, 1, [Are we building with zipfs enabled?])\
+ INSTALL_LIBRARIES=install-libraries-zipfs-shared
+ AC_MSG_RESULT([yes])
+ fi
+else
+AC_MSG_RESULT([no])
+INSTALL_LIBRARIES=install-libraries
+INSTALL_MSGS=install-msgs
+fi
+AC_SUBST(ZIPFS_BUILD)
+AC_SUBST(TK_ZIP_FILE)
+AC_SUBST(INSTALL_LIBRARIES)
+AC_SUBST(INSTALL_MSGS)
+
+
+#--------------------------------------------------------------------
# The statements below define various symbols relating to Tk
# stub support.
#--------------------------------------------------------------------