summaryrefslogtreecommitdiffstats
path: root/unix/configure.ac
diff options
context:
space:
mode:
authorculler <culler>2020-10-29 23:11:40 (GMT)
committerculler <culler>2020-10-29 23:11:40 (GMT)
commit7c2b11e38f243294c99694ea76897f087abc51b8 (patch)
tree889c77825f1722601bb51148d23d4a666ce86b66 /unix/configure.ac
parent085cde1d42e9a1a964a4ae5aeb9e186b698adc55 (diff)
downloadtk-7c2b11e38f243294c99694ea76897f087abc51b8.zip
tk-7c2b11e38f243294c99694ea76897f087abc51b8.tar.gz
tk-7c2b11e38f243294c99694ea76897f087abc51b8.tar.bz2
Suggested updates to tip_325.
Diffstat (limited to 'unix/configure.ac')
-rw-r--r--unix/configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/unix/configure.ac b/unix/configure.ac
index 071ff05..92a9d75 100644
--- a/unix/configure.ac
+++ b/unix/configure.ac
@@ -1,4 +1,4 @@
-#! /bin/bash -norc
+! /bin/bash -norc
dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
@@ -340,6 +340,9 @@ fi
if test $tk_aqua = yes; then
AC_DEFINE(MAC_OSX_TK, 1, [Are we building TkAqua?])
LIBS="$LIBS -framework Cocoa -framework Carbon -framework IOKit"
+ if test -d /System/Library/Frameworks/UserNotifications.framework; then
+ LIBS="$LIBS -framework UserNotifications"
+ fi
EXTRA_CC_SWITCHES='-std=gnu99 -x objective-c'
TK_WINDOWINGSYSTEM=AQUA
if test -n "${enable_symbols}" -a "${enable_symbols}" != no; then