summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2013-05-23 08:30:25 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2013-05-23 08:30:25 (GMT)
commit87bf3a06657cebfa60f9342700840162a8053df5 (patch)
tree8d7a4dd933cb624ade75995443ca4b51f07eb6db /unix/configure.in
parente1e1944517d89e734f0a5068ac86cd7f2395841c (diff)
parent586b77aea13cf6128fc8d09fbfff887ab9838545 (diff)
downloadtk-87bf3a06657cebfa60f9342700840162a8053df5.zip
tk-87bf3a06657cebfa60f9342700840162a8053df5.tar.gz
tk-87bf3a06657cebfa60f9342700840162a8053df5.tar.bz2
Fix for [3613668] by not calling XInitThreads when either 1) Tcl is compiled without threads 2) X11 library is too old.
A more direct test would be more desirable, but for now this should be fine.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 3c59369..bc22472 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -589,6 +589,25 @@ if test $tk_aqua = no; then
fi
#--------------------------------------------------------------------
+# Check whether XKeycodeToKeysym is deprecated in X11 headers.
+#--------------------------------------------------------------------
+
+if test $tk_aqua = no; then
+ AC_MSG_CHECKING([whether XKeycodeToKeysym is deprecated])
+ tk_oldCFlags=$CFLAGS
+ CFLAGS="$CFLAGS -Werror"
+ AC_TRY_LINK([
+ #include <X11/Xlib.h>
+ ], [
+ XKeycodeToKeysym(0,0,0);
+ ], [
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(XKEYCODETOKEYSYM_IS_DEPRECATED, 1, [Is XKeycodeToKeysym deprecated?])
+ ], AC_MSG_RESULT([no]))
+ CFLAGS=$tk_oldCFlags
+fi
+
+#--------------------------------------------------------------------
# XXX Do this last.
# It might modify XLIBSW which could affect other tests.
#