summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authordgp <dgp@users.sourceforge.net>2016-03-03 19:19:29 (GMT)
committerdgp <dgp@users.sourceforge.net>2016-03-03 19:19:29 (GMT)
commit2fd9fcf08d73f688888ef8784be0c5493b80d818 (patch)
tree9406a394d30d22c961a09ad039a8d5450172a4ed /win/configure.in
parent9d05857f2e1878b20cc6aa7cd5c87ed5c55aeea5 (diff)
downloadtk-2fd9fcf08d73f688888ef8784be0c5493b80d818.zip
tk-2fd9fcf08d73f688888ef8784be0c5493b80d818.tar.gz
tk-2fd9fcf08d73f688888ef8784be0c5493b80d818.tar.bz2
Bump trunk to 8.7a0 to accept new feature development.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/win/configure.in b/win/configure.in
index 0ff9304..cdef517 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -4,17 +4,17 @@
# to configure the system for the local environment.
AC_INIT(../generic/tk.h)
-AC_PREREQ(2.59)
+AC_PREREQ(2.69)
# The following define is needed when building with Cygwin since newer
# versions of autoconf incorrectly set SHELL to /bin/bash instead of
# /bin/sh. The bash shell seems to suffer from some strange failures.
SHELL=/bin/sh
-TK_VERSION=8.6
+TK_VERSION=8.7
TK_MAJOR_VERSION=8
-TK_MINOR_VERSION=6
-TK_PATCH_LEVEL=".5"
+TK_MINOR_VERSION=7
+TK_PATCH_LEVEL="a0"
VER=$TK_MAJOR_VERSION$TK_MINOR_VERSION
#------------------------------------------------------------------------
@@ -83,13 +83,13 @@ SC_LOAD_TCLCONFIG
if test "${TCL_MAJOR_VERSION}" != "${TK_MAJOR_VERSION}"; then
AC_MSG_ERROR([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
-Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
-Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
+Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl 8.6+.
+Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl 8.6 or better.])
fi
-if test "${TCL_MINOR_VERSION}" -lt "${TK_MINOR_VERSION}"; then
+if test "${TCL_MINOR_VERSION}" -lt 6; then
AC_MSG_ERROR([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
-Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
-Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
+Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl 8.6+.
+Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl 8.6 or better.])
fi
#--------------------------------------------------------------------