summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2003-03-19 03:14:41 (GMT)
committermdejong <mdejong>2003-03-19 03:14:41 (GMT)
commita2ca0faf6d40b076eb7a6f9ec23f6b4fe3b4c9e9 (patch)
treee4b127bff085de8888785db6e33f883c72e276f8 /win/configure.in
parentac8f14c105d1988c7d164c4da884550744652264 (diff)
downloadtk-a2ca0faf6d40b076eb7a6f9ec23f6b4fe3b4c9e9.zip
tk-a2ca0faf6d40b076eb7a6f9ec23f6b4fe3b4c9e9.tar.gz
tk-a2ca0faf6d40b076eb7a6f9ec23f6b4fe3b4c9e9.tar.bz2
* win/configure: Regen.
* win/configure.in: Don't run the AC_CYGWIN macro since it uses AC_CANONICAL_HOST under autoconf 2.5X. Just check to see if __CYGWIN__ is defined by the compiler and set the ac_cv_cygwin variable based on that. [Tcl Bug 705912]
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in26
1 files changed, 23 insertions, 3 deletions
diff --git a/win/configure.in b/win/configure.in
index 88c0617..835786c 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tk installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.51 2003/03/13 10:54:49 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.52 2003/03/19 03:14:42 mdejong Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.57)
@@ -72,10 +72,30 @@ fi
AC_PROG_MAKE_SET
#--------------------------------------------------------------------
-# These two macros perform additinal compiler test.
+# Perform additinal compiler tests.
#--------------------------------------------------------------------
-AC_CYGWIN
+dnl Currently AC_CYGWIN is disabled since it invokes AC_CANONICAL_HOST
+dnl under autoconf 2.5X.
+dnl
+dnl AC_CYGWIN
+
+AC_CACHE_CHECK(for Cygwin version of gcc,
+ ac_cv_cygwin,
+AC_TRY_COMPILE([
+#ifdef __CYGWIN__
+#error cygwin
+#endif
+],
+[],
+ ac_cv_cygwin=no,
+ ac_cv_cygwin=yes)
+)
+if test "$ac_cv_cygwin" = "yes" ; then
+ AC_MSG_ERROR([Compiling under Cygwin is not currently supported.
+A maintainer for the Cygwin port of Tcl/Tk is needed. See the README
+file for information about building with Mingw.])
+fi
#--------------------------------------------------------------------
# Determines the correct binary file extension (.o, .obj, .exe etc.)