summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authornijtmans <nijtmans>2010-11-18 22:49:44 (GMT)
committernijtmans <nijtmans>2010-11-18 22:49:44 (GMT)
commitc5351831b1c0464bc8b3f2cba1189b71200e7c9c (patch)
treed5dacab485d4319d24a5dc389fb95b56e71b11c6 /win/configure.in
parent198b86d147338c27a4db94272fc6ead2c900c342 (diff)
downloadtk-c5351831b1c0464bc8b3f2cba1189b71200e7c9c.zip
tk-c5351831b1c0464bc8b3f2cba1189b71200e7c9c.tar.gz
tk-c5351831b1c0464bc8b3f2cba1189b71200e7c9c.tar.bz2
Allow cross-compilation by default.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in30
1 files changed, 4 insertions, 26 deletions
diff --git a/win/configure.in b/win/configure.in
index 6e2a630..4ab033b 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tk installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.90 2010/08/27 00:57:50 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.91 2010/11/18 22:49:44 nijtmans Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.59)
@@ -46,31 +46,9 @@ AC_PROG_CC
AC_C_INLINE
AC_HEADER_STDC
-# To properly support cross-compilation, one would
-# need to use these tool checks instead of
-# the ones below and reconfigure with
-# autoconf 2.50. You can also just set
-# the CC, AR, RANLIB, and RC environment
-# variables if you want to cross compile.
-dnl AC_CHECK_TOOL(AR, ar)
-dnl AC_CHECK_TOOL(RANLIB, ranlib)
-dnl AC_CHECK_TOOL(RC, windres)
-
-if test "${GCC}" = "yes" ; then
- AC_CHECK_PROG(AR, ar, ar)
- AC_CHECK_PROG(RANLIB, ranlib, ranlib)
- AC_CHECK_PROG(RC, windres, windres)
-
- if test "${AR}" = "" ; then
- AC_MSG_ERROR([Required archive tool 'ar' not found on PATH.])
- fi
- if test "${RANLIB}" = "" ; then
- AC_MSG_ERROR([Required archive index tool 'ranlib' not found on PATH.])
- fi
- if test "${RC}" = "" ; then
- AC_MSG_ERROR([Required resource tool 'windres' not found on PATH.])
- fi
-fi
+AC_CHECK_TOOL(AR, ar)
+AC_CHECK_TOOL(RANLIB, ranlib)
+AC_CHECK_TOOL(RC, windres)
#--------------------------------------------------------------------
# Checks to see if the make progam sets the $MAKE variable.