summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortreectrl <treectrl>2007-02-02 20:32:08 (GMT)
committertreectrl <treectrl>2007-02-02 20:32:08 (GMT)
commit53e39d3c33e3af7c67cf135f85856349c228ca7d (patch)
tree27c199e3214506dbf401a461e9c608a1dfb9d99a /configure.ac
parent8c8d065f2b590880a30abe0575b6a88525fe38f3 (diff)
downloadtktreectrl-53e39d3c33e3af7c67cf135f85856349c228ca7d.zip
tktreectrl-53e39d3c33e3af7c67cf135f85856349c228ca7d.tar.gz
tktreectrl-53e39d3c33e3af7c67cf135f85856349c228ca7d.tar.bz2
Bumped version to 2.2.3.
Added --enable-shellicon (default=no) option which will run shellicon/configure on Win32 only. Pass -DTREECTRL_DEBUG to the compiler when --enable-symbols is not "no".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3576041..a46e900 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.ac,v 1.20 2007/01/22 22:43:58 treectrl Exp $
+# RCS: @(#) $Id: configure.ac,v 1.21 2007/02/02 20:32:08 treectrl Exp $
#-----------------------------------------------------------------------
# Sample configure.in for Tcl Extensions.
@@ -20,7 +20,7 @@ dnl to configure the system for the local environment.
#-----------------------------------------------------------------------
AC_INIT([treectrl], [2.2])
-AC_SUBST([PACKAGE_PATCHLEVEL], [2.2.2])
+AC_SUBST([PACKAGE_PATCHLEVEL], [2.2.3])
AC_DEFINE_UNQUOTED(PACKAGE_PATCHLEVEL, "$PACKAGE_PATCHLEVEL")
TEA_INIT([3.5])
@@ -121,6 +121,14 @@ if test "${TEA_PLATFORM}" = "windows" ; then
AC_DEFINE(BUILD_treectrl)
CLEANFILES="pkgIndex.tcl *.lib *.dll *.exp *.ilk *.pdb vc*.pch"
TEA_ADD_LIBS([gdi32.lib user32.lib])
+
+ AC_ARG_ENABLE(shellicon,
+ AC_HELP_STRING([--enable-shellicon],
+ [build the shellicon extension (default: no)]),
+ [tcl_ok=$enableval], [tcl_ok=no])
+ if test "$tcl_ok" = "yes" ; then
+ AC_CONFIG_SUBDIRS(shellicon)
+ fi
else
CLEANFILES="pkgIndex.tcl"
fi
@@ -156,6 +164,10 @@ TEA_CONFIG_CFLAGS
TEA_ENABLE_SYMBOLS
+if test "${enable_symbols+set}" = set && test "$enable_symbols" != no; then
+ TEA_ADD_CFLAGS([-DTREECTRL_DEBUG])
+fi
+
#--------------------------------------------------------------------
# Everyone should be linking against the Tcl stub library. If you
# can't for some reason, remove this definition. If you aren't using