summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-10-08 00:24:59 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-10-08 00:24:59 (GMT)
commit8daf2ea0a7192e556cc059c2220469ea22155380 (patch)
tree20494f647dad5dbea56f9c0a5b7241d1e9e3c7f7 /CMakeLists.txt
parent3a8a7a56ab604c3cca49792973c8b0c6d8a089b9 (diff)
downloaduscxml-8daf2ea0a7192e556cc059c2220469ea22155380.zip
uscxml-8daf2ea0a7192e556cc059c2220469ea22155380.tar.gz
uscxml-8daf2ea0a7192e556cc059c2220469ea22155380.tar.bz2
More fixes for MSVC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 077368a..b1d5bcf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -688,6 +688,9 @@ SET(USCXML_LANGUAGE_BINDINGS)
add_subdirectory(src/uscxml)
include_directories(${USCXML_INCLUDE_DIRS})
+if (WIN32)
+ list(APPEND USCXML_FILES "${PROJECT_SOURCE_DIR}/contrib/src/getopt/getopt.c")
+endif()
if (UNIX AND NOT APPLE)
list (APPEND USCXML_CORE_LIBS "rt")
@@ -757,7 +760,7 @@ if (NOT CMAKE_CROSSCOMPILING)
endif()
if (NOT CMAKE_CROSSCOMPILING)
- add_executable(uscxml-browser apps/uscxml-browser.cpp ${PROJECT_SOURCE_DIR}/contrib/src/getopt/XGetopt.cpp)
+ add_executable(uscxml-browser apps/uscxml-browser.cpp)
target_link_libraries(uscxml-browser uscxml)
set_target_properties(uscxml-browser PROPERTIES FOLDER "Apps")
install_executable(TARGETS uscxml-browser COMPONENT tools)