summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2015-01-19 16:41:18 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2015-01-19 16:41:18 (GMT)
commitff86d690dc02d7dd495000331d378e7d8eb688ac (patch)
tree5214786f7e575952d3cba0919e5071f3a783050b /CMakeLists.txt
parent42437db418574f2a80d098e568b9498a21343800 (diff)
downloaduscxml-ff86d690dc02d7dd495000331d378e7d8eb688ac.zip
uscxml-ff86d690dc02d7dd495000331d378e7d8eb688ac.tar.gz
uscxml-ff86d690dc02d7dd495000331d378e7d8eb688ac.tar.bz2
Plenty of smaller fixes and adaptations
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 789fb2b..edb8716 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1235,6 +1235,20 @@ if (NOT CMAKE_CROSSCOMPILING)
install_executable(TARGETS uscxml-transform COMPONENT tools)
if (WIN32)
+ add_executable(uscxml-analyze apps/uscxml-analyze.cpp ${PROJECT_SOURCE_DIR}/contrib/src/getopt/getopt.c)
+ else()
+ add_executable(uscxml-analyze apps/uscxml-analyze.cpp)
+ endif()
+ target_link_libraries(uscxml-analyze uscxml uscxml_transform)
+ if (NOT CMAKE_CROSSCOMPILING)
+ if (ENABLE_COTIRE)
+ set_target_properties(uscxml-analyze PROPERTIES COTIRE_ADD_UNITY_BUILD FALSE)
+ endif()
+ endif()
+ set_target_properties(uscxml-analyze PROPERTIES FOLDER "Apps")
+ install_executable(TARGETS uscxml-analyze COMPONENT tools)
+
+ if (WIN32)
add_executable(uscxml-dot apps/uscxml-dot.cpp ${PROJECT_SOURCE_DIR}/contrib/src/getopt/getopt.c)
else()
add_executable(uscxml-dot apps/uscxml-dot.cpp)