summaryrefslogtreecommitdiffstats
path: root/src/uscxml/plugins/ioprocessor/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-06-06 17:58:03 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-06-06 17:58:03 (GMT)
commite5a393584b030ac90c4e7abf65063ef72b910555 (patch)
treebfab1a3c3e4a1c8fc5dc3d27bd1b4f0044901293 /src/uscxml/plugins/ioprocessor/CMakeLists.txt
parent4ecca617e628e94845dafafbdee46ce57f7bc843 (diff)
downloaduscxml-e5a393584b030ac90c4e7abf65063ef72b910555.zip
uscxml-e5a393584b030ac90c4e7abf65063ef72b910555.tar.gz
uscxml-e5a393584b030ac90c4e7abf65063ef72b910555.tar.bz2
Changed getNames signature from set to list
Diffstat (limited to 'src/uscxml/plugins/ioprocessor/CMakeLists.txt')
-rw-r--r--src/uscxml/plugins/ioprocessor/CMakeLists.txt17
1 files changed, 16 insertions, 1 deletions
diff --git a/src/uscxml/plugins/ioprocessor/CMakeLists.txt b/src/uscxml/plugins/ioprocessor/CMakeLists.txt
index 7480b6b..f09a866 100644
--- a/src/uscxml/plugins/ioprocessor/CMakeLists.txt
+++ b/src/uscxml/plugins/ioprocessor/CMakeLists.txt
@@ -11,6 +11,8 @@ if (BUILD_AS_PLUGINS)
"../Plugins.cpp")
target_link_libraries(ioprocessor_sample uscxml)
set_target_properties(ioprocessor_sample PROPERTIES FOLDER "Plugin IOProcessor")
+ set_target_properties(ioprocessor_sample PROPERTIES COMPILE_FLAGS "-DPLUMA_EXPORTS")
+ set_target_properties(ioprocessor_sample PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${OUTPUT_DIR}/lib")
else()
list (APPEND USCXML_FILES ${SAMPLE_IOPROCESSOR})
endif()
@@ -28,6 +30,8 @@ if (BUILD_AS_PLUGINS)
"../Plugins.cpp")
target_link_libraries(ioprocessor_comet uscxml)
set_target_properties(ioprocessor_comet PROPERTIES FOLDER "Plugin IOProcessor")
+ set_target_properties(ioprocessor_comet PROPERTIES COMPILE_FLAGS "-DPLUMA_EXPORTS")
+ set_target_properties(ioprocessor_comet PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${OUTPUT_DIR}/lib")
else()
list (APPEND USCXML_FILES ${COMET_IOPROCESSOR})
endif()
@@ -48,6 +52,8 @@ if (BUILD_AS_PLUGINS)
"../Plugins.cpp")
target_link_libraries(ioprocessor_basichttp uscxml)
set_target_properties(ioprocessor_basichttp PROPERTIES FOLDER "Plugin IOProcessor")
+ set_target_properties(ioprocessor_basichttp PROPERTIES COMPILE_FLAGS "-DPLUMA_EXPORTS")
+ set_target_properties(ioprocessor_basichttp PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${OUTPUT_DIR}/lib")
else()
list (APPEND USCXML_FILES ${BASICHTTP_IOPROCESSOR})
endif()
@@ -60,15 +66,22 @@ file(GLOB_RECURSE SCXML_IOPROCESSOR
scxml/*.cpp
scxml/*.h
)
+file(GLOB_RECURSE BASICHTTP_IOPROCESSOR
+ basichttp/*.cpp
+ basichttp/*.h
+)
if (BUILD_AS_PLUGINS)
source_group("" FILES ${SCXML_IOPROCESSOR})
add_library(
ioprocessor_scxml SHARED
${SCXML_IOPROCESSOR}
+ ${BASICHTTP_IOPROCESSOR}
"../Plugins.cpp")
# scxml ioprocessor is a basichttp ioprocessor
- target_link_libraries(ioprocessor_scxml ioprocessor_basichttp uscxml)
+ target_link_libraries(ioprocessor_scxml uscxml)
set_target_properties(ioprocessor_scxml PROPERTIES FOLDER "Plugin IOProcessor")
+ set_target_properties(ioprocessor_scxml PROPERTIES COMPILE_FLAGS "-DPLUMA_EXPORTS")
+ set_target_properties(ioprocessor_scxml PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${OUTPUT_DIR}/lib")
else()
list (APPEND USCXML_FILES ${SCXML_IOPROCESSOR})
endif()
@@ -107,6 +120,8 @@ if (PROTOBUF_FOUND AND OFF)
"../Plugins.cpp")
target_link_libraries(ioprocessor_mmi uscxml mmi_proto)
set_target_properties(ioprocessor_mmi PROPERTIES FOLDER "Plugin IOProcessor")
+ set_target_properties(ioprocessor_mmi PROPERTIES COMPILE_FLAGS "-DPLUMA_EXPORTS")
+ set_target_properties(ioprocessor_mmi PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${OUTPUT_DIR}/lib")
else()
list (APPEND USCXML_FILES ${MMI_IOPROCESSOR})
list (APPEND USCXML_OPT_LIBS mmi_proto)