summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <github@mintwerk.de>2016-10-25 11:59:18 (GMT)
committerStefan Radomski <github@mintwerk.de>2016-10-25 11:59:18 (GMT)
commit954a1eb75f2abc81da1e09701d700674f0baddfb (patch)
tree873eb6412e958ecd53214ddbd6a3e17465da5100 /test/CMakeLists.txt
parent1a1513c6497e8818eb2a92a8fbf77d4c60bc911e (diff)
downloaduscxml-954a1eb75f2abc81da1e09701d700674f0baddfb.zip
uscxml-954a1eb75f2abc81da1e09701d700674f0baddfb.tar.gz
uscxml-954a1eb75f2abc81da1e09701d700674f0baddfb.tar.bz2
Worked on PROMELA transformation
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index e14586c..b0c5114 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -32,8 +32,7 @@ USCXML_TEST_COMPILE(NAME test-snippets LABEL general/test-snippets FILES src/tes
# USCXML_TEST_COMPILE(NAME test-c89-parser LABEL general/test-c89-parser FILES src/test-c89-parser.cpp)
# test-stress is not an automated test
-add_executable(test-stress src/test-stress.cpp)
-target_link_libraries(test-stress uscxml)
+USCXML_TEST_COMPILE(BUILD_ONLY NAME test-stress LABEL general/test-stress FILES src/test-stress.cpp)
file(GLOB_RECURSE USCXML_WRAPPERS
${PROJECT_SOURCE_DIR}/src/bindings/swig/wrapped/*.cpp
@@ -41,6 +40,8 @@ file(GLOB_RECURSE USCXML_WRAPPERS
)
USCXML_TEST_COMPILE(NAME test-bindings LABEL general/test-bindings FILES ${USCXML_WRAPPERS} src/test-bindings.cpp)
+USCXML_TEST_COMPILE(NAME test-promela-parser LABEL general/test-promela-parser FILES src/test-promela-parser.cpp)
+target_link_libraries(test-promela-parser uscxml_transform)
# the one binary to test for pass / fail final states
add_executable(test-state-pass src/test-state-pass.cpp ${GETOPT_FILES})
@@ -134,14 +135,14 @@ if (NOT BUILD_MINIMAL)
"null"
"lua"
"c89"
- # "promela"
+ "promela"
# generated c source
"gen/c/ecma"
# "gen/c/xpath"
"gen/c/lua"
# "gen/c/promela"
- # "gen/vhdl/ecma"
+ "gen/vhdl/ecma"
# bindings
"binding/java/jexl"
@@ -153,7 +154,7 @@ if (NOT BUILD_MINIMAL)
# "fsm/promela"
# formal verification
- # "spin/promela"
+ "spin/promela"
# performance tests
# "perf/gen/c/ecma"