summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <github@mintwerk.de>2017-05-22 19:17:48 (GMT)
committerStefan Radomski <github@mintwerk.de>2017-05-22 19:17:48 (GMT)
commit9a70ea561fecf533451f08ee3a490e2a5ba21372 (patch)
tree6ca253c6aa8640d50ca93d104a19421ec8ec2e3f /test/CMakeLists.txt
parentecdefbdbb55c800f9ceed67f77592b5d64927225 (diff)
downloaduscxml-9a70ea561fecf533451f08ee3a490e2a5ba21372.zip
uscxml-9a70ea561fecf533451f08ee3a490e2a5ba21372.tar.gz
uscxml-9a70ea561fecf533451f08ee3a490e2a5ba21372.tar.bz2
Fixed issue 135 custom executable content
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 61aa218..7f8187f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -47,7 +47,14 @@ endfunction()
# simple one file tests
USCXML_TEST_COMPILE(NAME test-utils LABEL general/test-utils FILES src/test-utils.cpp)
if(WITH_DM_LUA AND NOT BUILD_AS_PLUGINS)
- USCXML_TEST_COMPILE(NAME test-extensions LABEL general/test-extensions FILES src/test-extensions.cpp ../contrib/src/uscxml/PausableDelayedEventQueue.cpp ../contrib/src/uscxml/ExtendedLuaDataModel.cpp)
+ USCXML_TEST_COMPILE(
+ NAME test-extensions
+ LABEL general/test-extensions
+ FILES
+ src/test-extensions.cpp
+ ../contrib/src/uscxml/PausableDelayedEventQueue.cpp
+ ../contrib/src/uscxml/ExtendedLuaDataModel.cpp
+ ../contrib/src/uscxml/CustomExecutableContent.cpp)
endif()
USCXML_TEST_COMPILE(NAME test-url LABEL general/test-url FILES src/test-url.cpp)
USCXML_TEST_COMPILE(NAME test-lifecycle LABEL general/test-lifecycle FILES src/test-lifecycle.cpp)