summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8112d10..7906396 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,6 +25,10 @@ include("${CMAKE_MODULE_PATH}/USCXMLMacros.cmake")
# use folders in the IDEs for the various targets
set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+# compile with fPIC if required
+# see https://stackoverflow.com/questions/38296756/what-is-the-idiomatic-way-in-cmake-to-add-the-fpic-compiler-option
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+
# use rpath with MacOSX
set(CMAKE_MACOSX_RPATH 1)