summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Maybee <paulmay@microsoft.com>2023-07-29 17:23:43 (GMT)
committerBrad King <brad.king@kitware.com>2023-08-17 14:11:33 (GMT)
commit8b1257e7bf821461e6e0d92bf57e1c4ed885ddf9 (patch)
tree9ce28af2bff1b6c1d6f97f3e105849d3fe7829f4 /Source/CMakeLists.txt
parentb0054dd65c1d69a437abe85d27e704326884a9c2 (diff)
downloadCMake-8b1257e7bf821461e6e0d92bf57e1c4ed885ddf9.zip
CMake-8b1257e7bf821461e6e0d92bf57e1c4ed885ddf9.tar.gz
CMake-8b1257e7bf821461e6e0d92bf57e1c4ed885ddf9.tar.bz2
Debugger: Replace libuv with platform-specific connection code
Remove libuv usage from CMake debugger. Libuv has an async io model and cppdap uses a sync model, so an extra thread and a buffer copy were necessary to match semantics. In order to eliminate those costs this commit implements the IO using platform specific APIs.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 708aec7..4c5b4e3 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -775,8 +775,6 @@ if(CMake_ENABLE_DEBUGGER)
cmDebuggerBreakpointManager.h
cmDebuggerExceptionManager.cxx
cmDebuggerExceptionManager.h
- cmDebuggerPipeConnection.cxx
- cmDebuggerPipeConnection.h
cmDebuggerProtocol.cxx
cmDebuggerProtocol.h
cmDebuggerSourceBreakpoint.cxx
@@ -794,6 +792,21 @@ if(CMake_ENABLE_DEBUGGER)
cmDebuggerVariablesManager.cxx
cmDebuggerVariablesManager.h
)
+ if(WIN32)
+ target_sources(
+ CMakeLib
+ PRIVATE
+ cmDebuggerWindowsPipeConnection.cxx
+ cmDebuggerWindowsPipeConnection.h
+ )
+ else()
+ target_sources(
+ CMakeLib
+ PRIVATE
+ cmDebuggerPosixPipeConnection.cxx
+ cmDebuggerPosixPipeConnection.h
+ )
+ endif()
target_link_libraries(CMakeLib PUBLIC cppdap::cppdap)
endif()
@@ -945,7 +958,6 @@ if(CMake_BUILD_PCH)
"$<$<COMPILE_LANGUAGE:CXX>:cmArgumentParser.h>"
"$<$<COMPILE_LANGUAGE:CXX>:cmake.h>"
"$<$<COMPILE_LANGUAGE:CXX>:cmCMakePath.h>"
- "$<$<COMPILE_LANGUAGE:CXX>:cmDebuggerPipeConnection.h>"
"$<$<COMPILE_LANGUAGE:CXX>:cmCurl.h>")
set_source_files_properties(