summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 708aec7..4c5b4e3 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -775,8 +775,6 @@ if(CMake_ENABLE_DEBUGGER)
cmDebuggerBreakpointManager.h
cmDebuggerExceptionManager.cxx
cmDebuggerExceptionManager.h
- cmDebuggerPipeConnection.cxx
- cmDebuggerPipeConnection.h
cmDebuggerProtocol.cxx
cmDebuggerProtocol.h
cmDebuggerSourceBreakpoint.cxx
@@ -794,6 +792,21 @@ if(CMake_ENABLE_DEBUGGER)
cmDebuggerVariablesManager.cxx
cmDebuggerVariablesManager.h
)
+ if(WIN32)
+ target_sources(
+ CMakeLib
+ PRIVATE
+ cmDebuggerWindowsPipeConnection.cxx
+ cmDebuggerWindowsPipeConnection.h
+ )
+ else()
+ target_sources(
+ CMakeLib
+ PRIVATE
+ cmDebuggerPosixPipeConnection.cxx
+ cmDebuggerPosixPipeConnection.h
+ )
+ endif()
target_link_libraries(CMakeLib PUBLIC cppdap::cppdap)
endif()
@@ -945,7 +958,6 @@ if(CMake_BUILD_PCH)
"$<$<COMPILE_LANGUAGE:CXX>:cmArgumentParser.h>"
"$<$<COMPILE_LANGUAGE:CXX>:cmake.h>"
"$<$<COMPILE_LANGUAGE:CXX>:cmCMakePath.h>"
- "$<$<COMPILE_LANGUAGE:CXX>:cmDebuggerPipeConnection.h>"
"$<$<COMPILE_LANGUAGE:CXX>:cmCurl.h>")
set_source_files_properties(