summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSteve Wilson <stevew@wolfram.com>2019-09-13 17:12:15 (GMT)
committerCristian Adam <cristian.adam@gmail.com>2019-09-28 13:56:53 (GMT)
commit9e66397c28110f015e5b044dfe9782cd5f11c8c3 (patch)
tree6febffa635898ae983996eb6fbc8b8875d80fb2d /Tests/CMakeLists.txt
parent80f120a85fb0992e3f06ad69ebdad881bea9af8c (diff)
downloadCMake-9e66397c28110f015e5b044dfe9782cd5f11c8c3.zip
CMake-9e66397c28110f015e5b044dfe9782cd5f11c8c3.tar.gz
CMake-9e66397c28110f015e5b044dfe9782cd5f11c8c3.tar.bz2
Languages: Add support for Objective-C++
Add entries in Modules and Modules/Platform to support Objective-C++ compiler determination and identification. Add Modules to check Objective-C++ compiler flags, source compilations, program checks, etc... Use OBJCXX as the designator of the language, eg: project(foo OBJCXX) Add various tests for Objective-C++ language features. Add tests to preserve C++ handling of .M and .mm files when Objective-C++ is not a configured language. Co-authored-by: Cristian Adam <cristian.adam@gmail.com>
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 2e17e59..789fc0e 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2365,6 +2365,42 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
)
list(APPEND TEST_BUILD_DIRS "${CMAKE_BINARY_DIR}/Tests/Objective-C/objc-file-extension-test")
+ add_test(Objective-CXX.simple-build-test ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/Objective-C++/simple-build-test"
+ "${CMake_BINARY_DIR}/Tests/Objective-C++/simple-build-test"
+ --build-two-config
+ ${build_generator_args}
+ --build-project simple-build-test
+ --build-options ${build_options}
+ --test-command simple-build-test
+ )
+ list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C++/simple-build-test")
+
+ add_test(Objective-CXX.cxx-file-extension-test ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/Objective-C++/cxx-file-extension-test"
+ "${CMake_BINARY_DIR}/Tests/Objective-C++/cxx-file-extension-test"
+ --build-two-config
+ ${build_generator_args}
+ --build-project cxx-file-extension-test
+ --build-options ${build_options}
+ --test-command cxx-file-extension-test
+ )
+ list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C++/cxx-file-extension-test")
+
+ add_test(Objective-CXX.objcxx-file-extension-test ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/Objective-C++/objcxx-file-extension-test"
+ "${CMake_BINARY_DIR}/Tests/Objective-C++/objcxx-file-extension-test"
+ --build-two-config
+ ${build_generator_args}
+ --build-project objcxx-file-extension-test
+ --build-options ${build_options}
+ --test-command objcxx-file-extension-test
+ )
+ list(APPEND TEST_BUILD_DIRS "${CMAKE_BINARY_DIR}/Tests/Objective-C++/objcxx-file-extension-test")
+
endif ()
endif ()