summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 2e17e59..789fc0e 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2365,6 +2365,42 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
)
list(APPEND TEST_BUILD_DIRS "${CMAKE_BINARY_DIR}/Tests/Objective-C/objc-file-extension-test")
+ add_test(Objective-CXX.simple-build-test ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/Objective-C++/simple-build-test"
+ "${CMake_BINARY_DIR}/Tests/Objective-C++/simple-build-test"
+ --build-two-config
+ ${build_generator_args}
+ --build-project simple-build-test
+ --build-options ${build_options}
+ --test-command simple-build-test
+ )
+ list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C++/simple-build-test")
+
+ add_test(Objective-CXX.cxx-file-extension-test ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/Objective-C++/cxx-file-extension-test"
+ "${CMake_BINARY_DIR}/Tests/Objective-C++/cxx-file-extension-test"
+ --build-two-config
+ ${build_generator_args}
+ --build-project cxx-file-extension-test
+ --build-options ${build_options}
+ --test-command cxx-file-extension-test
+ )
+ list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C++/cxx-file-extension-test")
+
+ add_test(Objective-CXX.objcxx-file-extension-test ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/Objective-C++/objcxx-file-extension-test"
+ "${CMake_BINARY_DIR}/Tests/Objective-C++/objcxx-file-extension-test"
+ --build-two-config
+ ${build_generator_args}
+ --build-project objcxx-file-extension-test
+ --build-options ${build_options}
+ --test-command objcxx-file-extension-test
+ )
+ list(APPEND TEST_BUILD_DIRS "${CMAKE_BINARY_DIR}/Tests/Objective-C++/objcxx-file-extension-test")
+
endif ()
endif ()