summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorGaƫtan Lehmann <gaetan.lehmann@gmail.com>2015-02-01 07:26:37 (GMT)
committerBrad King <brad.king@kitware.com>2015-02-03 18:26:35 (GMT)
commit1074cb11ebdc29bff2fc7eb633252348e0758106 (patch)
tree2a158ec4fefbd1124632f8231af122940a49147c /test/CMakeLists.txt
parent7cdf28e815b45e8584a7f06d457365f3f4963d02 (diff)
downloadCastXML-1074cb11ebdc29bff2fc7eb633252348e0758106.zip
CastXML-1074cb11ebdc29bff2fc7eb633252348e0758106.tar.gz
CastXML-1074cb11ebdc29bff2fc7eb633252348e0758106.tar.bz2
test: Add a case to test that -c is ignored
The '-c' option is required to use castxml with ccache to tell ccache that we are compiling rather than linking. In castxml we already ignore the option when used with --castxml-gccxml, so add a test case to ensure the behavior is preserved in the future.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 0942cf4..db8bc74 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -114,6 +114,7 @@ castxml_test_cmd(gccxml-and-objc1 --castxml-gccxml ${empty_m})
castxml_test_cmd(gccxml-and-objc2 --castxml-gccxml ${empty_mm})
castxml_test_cmd(gccxml-empty-c++98 --castxml-gccxml -std=c++98 ${empty_cxx})
castxml_test_cmd(gccxml-empty-c++98-E --castxml-gccxml -std=c++98 ${empty_cxx} -E)
+castxml_test_cmd(gccxml-empty-c++98-c --castxml-gccxml -std=c++98 ${empty_cxx} -c)
castxml_test_cmd(o-missing -o)
castxml_test_cmd(start-missing --castxml-start)
castxml_test_cmd(rsp-empty @${input}/empty.rsp)