summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-18 19:15:40 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-24 15:37:20 (GMT)
commit25ff73764f1a54a0c3689df949f2d7e9ab41a014 (patch)
tree21a70f6c0e31c684271767b094efb6ba1f22528d /test/CMakeLists.txt
parent5e0461f6741c5eed0ee1cf79e0517a3d9b93f3b2 (diff)
downloadCastXML-25ff73764f1a54a0c3689df949f2d7e9ab41a014.zip
CastXML-25ff73764f1a54a0c3689df949f2d7e9ab41a014.tar.gz
CastXML-25ff73764f1a54a0c3689df949f2d7e9ab41a014.tar.bz2
Output: Report Typedef underlying type
When a typedef is "moded" the underlying type may be different from the named type. Report the real type.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index e95af68..0441ce7 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -121,6 +121,7 @@ castxml_test_gccxml(Typedef-paren)
castxml_test_gccxml(Typedef-to-Class-template)
castxml_test_gccxml(Typedef-to-Enumeration)
castxml_test_gccxml(Typedef-to-Enumeration-anonymous)
+castxml_test_gccxml(Typedef-to-FundamentalType-mode)
castxml_test_gccxml(Variable)
castxml_test_gccxml(Variable-in-Class)
castxml_test_gccxml(Variable-init)