summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-02-12 21:21:01 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-21 18:40:20 (GMT)
commit44b2a79924734d5dc5ff1c7afeea4efb30ac6b54 (patch)
tree2624abb25a27c78bd407e3a42ffbe92c92bd4b7a /test/CMakeLists.txt
parent76c942fbf736356445ea9eabf4eccd1919ee2ce1 (diff)
downloadCastXML-44b2a79924734d5dc5ff1c7afeea4efb30ac6b54.zip
CastXML-44b2a79924734d5dc5ff1c7afeea4efb30ac6b54.tar.gz
CastXML-44b2a79924734d5dc5ff1c7afeea4efb30ac6b54.tar.bz2
Output: Generate Class, Struct, and Union elements
Implement the OutputRecordDecl and OutputCXXRecordDecl methods to generate Class, Struct, and Union elements. Report the name="", context="", location="", incomplete="", and members="" of the declaration. Queue its members. Also map record types to the corresponding declarations.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5eb89cd..a56f5ef 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -51,6 +51,8 @@ castxml_test_cmd(gccxml-twice --castxml-gccxml --castxml-gccxml)
castxml_test_cmd(o-missing -o)
castxml_test_cmd(start-missing --castxml-start)
+castxml_test_gccxml(Class)
+castxml_test_gccxml(Class-incomplete)
castxml_test_gccxml(CvQualifiedType)
castxml_test_gccxml(FundamentalType)
castxml_test_gccxml(Namespace)