summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-04-14 17:36:39 (GMT)
committerBrad King <brad.king@kitware.com>2014-04-14 17:37:53 (GMT)
commit68009c611d9fbf5ad8391e12e4d40c5716aee43e (patch)
tree3f8e1f58046e8d3fc948d393479d4c6ea89be1ea /test/CMakeLists.txt
parent2bba2e9e8900666ca92a7abb848ee8e5756462d8 (diff)
downloadCastXML-68009c611d9fbf5ad8391e12e4d40c5716aee43e.zip
CastXML-68009c611d9fbf5ad8391e12e4d40c5716aee43e.tar.gz
CastXML-68009c611d9fbf5ad8391e12e4d40c5716aee43e.tar.bz2
Output: Add function calling convention attributes
Add to Function-like and FunctionType elements an attributes="" attribute for the calling convention as gccxml does.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 22858aa..902f892 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -189,6 +189,7 @@ castxml_test_gccxml(using-directive-start)
if(";${LLVM_TARGETS_TO_BUILD};" MATCHES ";X86;")
set(castxml_test_gccxml_extra_arguments -target i386-pc-windows-msvc)
+ castxml_test_gccxml(Function-calling-convention-ms)
castxml_test_gccxml(implicit-decl-ms)
castxml_test_gccxml(inline-asm-ms)
unset(castxml_test_gccxml_extra_arguments)