summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-18 15:40:57 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-24 15:37:20 (GMT)
commit95c7a3dea54a7c23bf5fd3a9a7fd5adfe1f45414 (patch)
tree6712ab58b1ff81fea60c51a9df2e9ea2fca7db5e /test/CMakeLists.txt
parentfbc3aa539f7db36f949daeb37472b807d48e03c9 (diff)
downloadCastXML-95c7a3dea54a7c23bf5fd3a9a7fd5adfe1f45414.zip
CastXML-95c7a3dea54a7c23bf5fd3a9a7fd5adfe1f45414.tar.gz
CastXML-95c7a3dea54a7c23bf5fd3a9a7fd5adfe1f45414.tar.bz2
Output: Fix output of forward-declared classes
When adding a dump node for a class, use the class definition, if available, instead of the canonical declaration. They may not be the same when a class is forward-declared before it is defined. We need to use the definition to get all members.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index fb279cd..5bca07d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -83,6 +83,7 @@ castxml_test_gccxml(ArrayType-incomplete)
castxml_test_gccxml(Class)
castxml_test_gccxml(Class-abstract)
castxml_test_gccxml(Class-bases)
+castxml_test_gccxml(Class-forward)
castxml_test_gccxml(Class-friends)
castxml_test_gccxml(Class-incomplete)
castxml_test_gccxml(Class-member-template)