summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-31 15:12:11 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-31 15:17:14 (GMT)
commitacac132995f585d5ac0d9d2711bbf44e86b66597 (patch)
treee48930f08cb5d878fc76db844d4070ae04b1b90f /test/CMakeLists.txt
parent7b6294eef526429d1124acbdc258e09c8be217a3 (diff)
downloadCastXML-acac132995f585d5ac0d9d2711bbf44e86b66597.zip
CastXML-acac132995f585d5ac0d9d2711bbf44e86b66597.tar.gz
CastXML-acac132995f585d5ac0d9d2711bbf44e86b66597.tar.bz2
Output: Skip through extern "C" contexts to enclosing namespace
The gccxml output format has no representation for extern "C" declaration contexts, so simply report the enclosing namespace.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 158215a..ac60cd6 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -139,6 +139,7 @@ castxml_test_gccxml(Typedef-to-Class-template)
castxml_test_gccxml(Typedef-to-Enumeration)
castxml_test_gccxml(Typedef-to-Enumeration-anonymous)
castxml_test_gccxml(Typedef-to-FundamentalType-mode)
+castxml_test_gccxml(Typedef-to-extern-C-FundamentalType-mode)
castxml_test_gccxml(Variable)
castxml_test_gccxml(Variable-in-Class)
castxml_test_gccxml(Variable-init)