summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-02-26 20:49:35 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-21 21:05:12 (GMT)
commitb57a67a0c3d8accd0f83dc58102e75b15d26ad7b (patch)
tree7659ae37deeef0b18157ea84e7ff270b2435d8a5 /test/CMakeLists.txt
parentfa551b8b9703c5877ac653344c3e01b2ef4de98b (diff)
downloadCastXML-b57a67a0c3d8accd0f83dc58102e75b15d26ad7b.zip
CastXML-b57a67a0c3d8accd0f83dc58102e75b15d26ad7b.tar.gz
CastXML-b57a67a0c3d8accd0f83dc58102e75b15d26ad7b.tar.bz2
Output: Generate Field elements
Implement the OutputFieldDecl method to generate the Field element. Report the name="", type="", bits="", mutable="", context="", and location="" of the declaration. Queue the type.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 50c8343..df6bbe9 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -71,6 +71,7 @@ castxml_test_gccxml(Class)
castxml_test_gccxml(Class-incomplete)
castxml_test_gccxml(Class-template)
castxml_test_gccxml(CvQualifiedType)
+castxml_test_gccxml(Field)
castxml_test_gccxml(Function)
castxml_test_gccxml(Function-template)
castxml_test_gccxml(Function-throw)