summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-11 19:56:54 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-24 15:37:20 (GMT)
commitcfe97491eb0108dd7c8bc98c80426ae115cfe5f3 (patch)
tree0ac232db6471a8646664028cce62294cc27d79ea /test/CMakeLists.txt
parent66e499376acbff61aece11ed8c0cef59c05aca3a (diff)
downloadCastXML-cfe97491eb0108dd7c8bc98c80426ae115cfe5f3.zip
CastXML-cfe97491eb0108dd7c8bc98c80426ae115cfe5f3.tar.gz
CastXML-cfe97491eb0108dd7c8bc98c80426ae115cfe5f3.tar.bz2
test: Avoid duplication of path to test input directory
Store the path in a local "input" variable.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 112d3c3..d4c9d3c 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -52,10 +52,11 @@ macro(castxml_test_gccxml_c test)
castxml_test_gccxml_common(gccxml.c c -std=c89 ${test})
endmacro()
-set(empty_c ${CMAKE_CURRENT_LIST_DIR}/input/empty.c)
-set(empty_cxx ${CMAKE_CURRENT_LIST_DIR}/input/empty.cxx)
-set(empty_m ${CMAKE_CURRENT_LIST_DIR}/input/empty.m)
-set(empty_mm ${CMAKE_CURRENT_LIST_DIR}/input/empty.mm)
+set(input ${CMAKE_CURRENT_LIST_DIR}/input)
+set(empty_c ${input}/empty.c)
+set(empty_cxx ${input}/empty.cxx)
+set(empty_m ${input}/empty.m)
+set(empty_mm ${input}/empty.mm)
castxml_test_cmd(no-arguments)