summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2019-08-11 16:36:18 (GMT)
committeralbert-github <albert.tests@gmail.com>2019-08-11 16:36:18 (GMT)
commit46ecf6bf78f1c0d4aa140db74847fafc5613dfe7 (patch)
tree33260e4c67115c3478e6f60cc61eecf5b965073d /CMakeLists.txt
parent09c263e70a2ac9afbe8f7cc7a0a07c5ab069645a (diff)
downloadDoxygen-46ecf6bf78f1c0d4aa140db74847fafc5613dfe7.zip
Doxygen-46ecf6bf78f1c0d4aa140db74847fafc5613dfe7.tar.gz
Doxygen-46ecf6bf78f1c0d4aa140db74847fafc5613dfe7.tar.bz2
Generating doxygen's documentation in CHM format
Until now the chm format of the doxygen documentation was generated by a separate script, this is now integrated in the CMake procedure. - option -Dbuild_doc_chm to enable the possibility to generate the CHM documentation (only works for windows) - procedure is as follows - generate the base documentation for the CHM output - copy the documentation of the examples to the tree with the base CHM output (cannot use it from its default place due to the fact that in the next face the first page of the CHM file will be wrong - add the html, png, css and gif files of the examples to the so called hhp file (has to happen during runtime, hence a small python script, created inline so there is no extra file in the source tree) - create the resulting doxygen_manual.chm Some improvements during the process - the html files of the examples are added so that the full documentation of the examples is accessible and not just the top pages of the examples - keep the index terms of base chm file (mostly the commands and configuration parameters) - see to it that the doxygen logo is copied by doxygen and not by means of cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2621844..16e70ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,7 +19,8 @@ option(build_app "Example showing how to embed doxygen in an application."
option(build_parse "Parses source code and dumps the dependencies between the code elements." OFF)
option(build_xmlparser "Example showing how to parse doxygen's XML output." OFF)
option(build_search "Build external search tools (doxysearch and doxyindexer)" OFF)
-option(build_doc "Build user manual" OFF)
+option(build_doc "Build user manual (HTML and PDF)" OFF)
+option(build_doc_chm "Build user manual (CHM)" OFF)
option(use_sqlite3 "Add support for sqlite3 output [experimental]." OFF)
option(use_libclang "Add support for libclang parsing." OFF)
option(win_static "Link with /MT in stead of /MD on windows" OFF)
@@ -160,6 +161,16 @@ add_subdirectory(qtools)
add_subdirectory(vhdlparser)
add_subdirectory(src)
+if (build_doc_chm)
+ if (WIN32)
+ find_package(HTMLHelp REQUIRED)
+ set(build_doc ON)
+ else ()
+ message(WARNING "CHM documentation genetration not supported for this platform, ignoring setting.")
+ set(build_doc_chm OFF)
+ endif ()
+endif ()
+
if (build_doc)
add_subdirectory(examples)
add_subdirectory(doc)