summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2621844..16e70ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,7 +19,8 @@ option(build_app "Example showing how to embed doxygen in an application."
option(build_parse "Parses source code and dumps the dependencies between the code elements." OFF)
option(build_xmlparser "Example showing how to parse doxygen's XML output." OFF)
option(build_search "Build external search tools (doxysearch and doxyindexer)" OFF)
-option(build_doc "Build user manual" OFF)
+option(build_doc "Build user manual (HTML and PDF)" OFF)
+option(build_doc_chm "Build user manual (CHM)" OFF)
option(use_sqlite3 "Add support for sqlite3 output [experimental]." OFF)
option(use_libclang "Add support for libclang parsing." OFF)
option(win_static "Link with /MT in stead of /MD on windows" OFF)
@@ -160,6 +161,16 @@ add_subdirectory(qtools)
add_subdirectory(vhdlparser)
add_subdirectory(src)
+if (build_doc_chm)
+ if (WIN32)
+ find_package(HTMLHelp REQUIRED)
+ set(build_doc ON)
+ else ()
+ message(WARNING "CHM documentation genetration not supported for this platform, ignoring setting.")
+ set(build_doc_chm OFF)
+ endif ()
+endif ()
+
if (build_doc)
add_subdirectory(examples)
add_subdirectory(doc)