summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2019-05-31 18:03:45 (GMT)
committeralbert-github <albert.tests@gmail.com>2019-05-31 18:03:45 (GMT)
commit4ad23e5d18fc294e00844fd8557f8c5dd6254d6e (patch)
tree54add50b60dc75b677dc62afc84aad4014b0d9a2 /CMakeLists.txt
parentfa9dda01e6c013c7fe9be99b21d8bbf3c95c0482 (diff)
downloadDoxygen-4ad23e5d18fc294e00844fd8557f8c5dd6254d6e.zip
Doxygen-4ad23e5d18fc294e00844fd8557f8c5dd6254d6e.tar.gz
Doxygen-4ad23e5d18fc294e00844fd8557f8c5dd6254d6e.tar.bz2
Show git version information
The original version has as features: - getting the git version number for usage in doxygen - making the doxygen version number inclusion dependent on the VERSION file The disadvantage of the chosen methodology was that an extra correction step was necessary, by defining getter methods to retrieve the values this correction can be hidden. The information is coming from different sources: - the VERSION file - the git "repository and build system (when present) Furthermore there are a couple of places where the version information is used (a.o. doxygen and doxywizard executable, though the doxygenwizard was only done "half hearted") The handling of the VERSION file has been made in such a way that it is comparable with the generation of the git version changes. For a better abstraction the version handling is all done in a separate directory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c116bbb..05ab57b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,10 +110,6 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_RELEASE ${EXECUTABLE_OUTPUT_PATH})
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_MINSIZEREL ${EXECUTABLE_OUTPUT_PATH})
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_RELWITHDEBINFO ${EXECUTABLE_OUTPUT_PATH})
-# setup information for git version handling
-set(PRE_CONFIGURE_GIT_VERSION_FILE "${CMAKE_SOURCE_DIR}/src/gitversion.cpp.in")
-set(POST_CONFIGURE_GIT_VERSION_FILE "${GENERATED_SRC}/gitversion.cpp")
-
# gather lang codes for translation
file(GLOB lang_files RELATIVE "${CMAKE_SOURCE_DIR}/src" "${CMAKE_SOURCE_DIR}/src/translator_??.h")
if (english_only) # user only wants English
@@ -147,6 +143,7 @@ endif()
add_subdirectory(libmd5)
+add_subdirectory(libversion)
add_subdirectory(qtools)
add_subdirectory(vhdlparser)
add_subdirectory(src)