summaryrefslogtreecommitdiffstats
path: root/testing/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <dimitri@stack.nl>2017-10-28 19:14:02 (GMT)
committerDimitri van Heesch <dimitri@stack.nl>2017-10-28 19:14:02 (GMT)
commit7ce59c9fbd5e99619a9ab0ac6177d21e6aca49c7 (patch)
tree1f64772016651893e622e88225d8db142034aa93 /testing/CMakeLists.txt
parent2a973de8e473eb455ed176f9bd3a4c630b92afd9 (diff)
downloadDoxygen-7ce59c9fbd5e99619a9ab0ac6177d21e6aca49c7.zip
Doxygen-7ce59c9fbd5e99619a9ab0ac6177d21e6aca49c7.tar.gz
Doxygen-7ce59c9fbd5e99619a9ab0ac6177d21e6aca49c7.tar.bz2
Restore 'make tests' rule
Diffstat (limited to 'testing/CMakeLists.txt')
-rw-r--r--testing/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/testing/CMakeLists.txt b/testing/CMakeLists.txt
index 84162ea..97b4868 100644
--- a/testing/CMakeLists.txt
+++ b/testing/CMakeLists.txt
@@ -1,3 +1,8 @@
+add_custom_target(tests
+ COMMENT "Running doxygen tests..."
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/testing/runtests.py --all --doxygen ${PROJECT_BINARY_DIR}/bin/doxygen --inputdir ${CMAKE_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing
+ DEPENDS doxygen
+)
add_test(NAME suite
COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/testing/runtests.py --all --doxygen $<TARGET_FILE:doxygen> --inputdir ${CMAKE_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing
)